Jump to content
  • Announcements

    • spinynorman

      Mandriva Official Documentation

      Official documentation for extant versions of Mandriva can be found at doc.mandriva.com.   Documentation for the latest release may take some time to appear there. You can install all the manuals from the main repository if you have Mandriva installed - files are prefixed mandriva-doc.
    • paul

      Forum software upgrade   10/29/17

      So you may have noticed the forum software has upgraded !!!
      A few things that have changed. We no longer have community blogs (was never really used) We no longer have a portal page.
      We can discuss this, and decide whether it is needed (It costs money) See this thread: Here
tf1

Mixer channels missing in kmix [solved]

Recommended Posts

Hi Chaps

 

Just installed 2010.2, works great.

 

Problem is when i click on the sound applet and choose mixer, kmix shows only one channel "internal audio analog stereo" no others are available, used to be just fine in 2010, where I could choose from a multitude of channels. I need to get to the channels to mute one of them (can't remember which one) because with it unmuted my mouse makes a noise through the speakers when it is moved, it's very annoying

 

Any ideas what I need to do, the driver is the same as far as I can recollect and it's using Alsa with Pulse audio enabled.

 

Thanks

Edited by tf1

Share this post


Link to post
Share on other sites

Hi tfi, you may want to disable pulse audio in mcc. Then depending on what card your system reports it as you should get some more options in the sound control setup in KDE, if you are running KDE that is. I have a laptop the creates an awful scratchy type sound if I have the modem speaker unmuted. My pc gives me the same mixer control as you describe with pulse enabled.

Disable pulse and see what you get.

Share this post


Link to post
Share on other sites

Both "aumix" and "alsamixer" have more options and may do what tf1 wants without having to disable pulse audio.

 

Ken

Share this post


Link to post
Share on other sites

Thanks, I managed to get the channels back by disabling Pulse audio. I had tried before posting, but didn't realize you had to reboot instead of just log out\in. I found that on an earlier post by SilverSsurfer60. The channel causing the problem was the "phone" channel. Sound is now perfect.

 

What are the advantages of using Pulse audio? I may experiment with PA and try aumix or alsamixer, as Ken suggested. Would there be any benefit?

 

Edit: If I swapped back to PA, would the phone channel stay muted?

 

Cheers

Edited by tf1

Share this post


Link to post
Share on other sites
Guest
You are commenting as a guest. If you have an account, please sign in.
Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoticons maximum are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.

Loading...

×