Jump to content
  • Announcements

    • spinynorman

      Mandriva Official Documentation

      Official documentation for extant versions of Mandriva can be found at doc.mandriva.com.   Documentation for the latest release may take some time to appear there. You can install all the manuals from the main repository if you have Mandriva installed - files are prefixed mandriva-doc.
    • paul

      Forum software upgrade   10/29/17

      So you may have noticed the forum software has upgraded !!!
      A few things that have changed. We no longer have community blogs (was never really used) We no longer have a portal page.
      We can discuss this, and decide whether it is needed (It costs money) See this thread: Here
Sign in to follow this  
kslinux

Epson Stylus NX420 continuously feeds paper

Recommended Posts

I bought an EPSON NX420 printer. When I connected it to my USB port, Mandriva 2010 recognized it and loaded the "NX400 - Cups + Gutenprint v5.2.4" print driver.

 

When asked to print the Test Page, I clicked OK. It printed the top part of the header which reads "Printer Test Page" and then it kept feeding page after page of paper through the printer until it ran out of paper --- no printing on those pages.

 

I am NOT very knowledgable about LINUX. Please treat me as a newbie and lead me through any suggestions you may have. I know how to get to the command line, but again assume I know nothing. If I need to run some commands, please be specific and I'll try to provide you the results.

 

A couple of other notes. I have NOT updated Mandriva to 2010.1. Mandriva 2010 has been working fine for me. I have Mandriva 2010 installed on a circa 2006 Sony Vaio laptop. I am dual booting with Windows XP.

 

Thanks for your help!

 

Alan

Share this post


Link to post
Share on other sites

See if you have the following installed, or something similar:

epson-inkjet-printer-nx420-1.0.0-1lsb3.2.i486.rpm

 

You can enter the following command in terminal to find out:

rpm -qa epson*

 

You can get the above driver from:

http://linux.avasys.jp/drivers/lsb/epson-inkjet/stable/RPMS/i486/epson-inkjet-printer-nx420-1.0.0-1lsb3.2.i486.rpm

 

After downloading, right-click on the file in /home/~/Downloads/

Then choose "Open with Software installer".

 

See the following:

http://www.openprinting.org/printer/Epson/Epson-NX420_Series

Share this post


Link to post
Share on other sites

I had to add the driver. Initially, it would not load because a "process" had locked the rpm database. I killed the process, and it loaded OK with a lot of dependencies. Still would not print properly. I tried printing the web page and got a lot of garbage on multiple pages.

 

I thought maybe the i486 was the wrong driver. I have the 64-bit version of Mandriva 2010 loaded (sorry for not providing that information sooner). I went out to the website (http://linux.avasys/), found the x86_64 driver and loaded it. I tried printing an OpenOffice Calc page and got nothing but the printer feeding through blank pages.

 

I double checked the suggested command and got the following:

 

# rpm -qa epson*

epson-inkjet-printer-nx420-1.0.0-1lsb3.2

 

Any suggestions?

 

Alan

Share this post


Link to post
Share on other sites

Only that sometimes the printer or the computer get out of whack with each other. Try rebooting the computer and turning the printer off and back on again. Make sure and allow enough time for everything to be fully loaded up, then try printing again.

 

You might have to delete the printer in CUPS, then readd the printer and make sure you select the driver you just installed.

Edited by David Batson

Share this post


Link to post
Share on other sites

The computer and the printer have been off for days. Turned everything on and still doesn't work.

 

Went into the "Configure your Computer" window, deleted the printer, added the printer; still doesn't work. Did the 15-20 minute self diagnostic for the Epson NX-420. Tried printing a test page - test page is in the print queue and has the status of "stopped". Tried the "reprint" option, status goes from "processing" to "stopped".

 

Very frustrating that NOTHING WORKS!

 

Still not solved.

Share this post


Link to post
Share on other sites

Currently I am using 2010.0 as my main OS and have 2010-Spring installed to play around with.

I use an HP Photosmart B109a-m (Multi) and have the similar sort of trouble that you experience.

I have found that if I switch off the printer when not using it (energy saving of course) and just switch it back on, it will not print anything. Even rebooting does not fix the problem.

The only thing I have found to work is to DISCONNECT the USB cable for about 10 to 15 seconds and then reconnect it. A pop-up appears on the panel and then says it is connecting the printer.

It continues to work thereafter no matter how long the printer is powered so long as it is not switched off or rebooted.

Somewhere along the way the Mandriva team seems to have screwed up something that used to work perfectly and trouble free since 2009, however considering we now know what the wonderful staff at Mandriva were going through these past 2 years, I am not surprised. What is amazing is that, despite all their trauma, so very few screwups have occurred. To the Mandriva team (current) and former (now Mangeia team), a great big thank you all. :thumbs: :thumbs: :thumbs:

 

I hope my suggestion works for you too. Cheers. John.

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now
Sign in to follow this  

×