Jump to content
Sign in to follow this  
machschnell

L 99 99 99 error on boot after install

Recommended Posts

Total newbie to Linux, trying to install 9.1 from CD, everything goes fine, 15 mins later I reboot and get the error "L 99 99 99 99..." the '99' repeats itself about 100 times. I changed the BIOS to boot to the C drive after finishing the install.

 

I haven't found anything anywhere about this specific message, so I need some help.

 

Machine's a PII 333, 256 RAM, 13G drive. Previously had Windows 98 on it, I chose to have it erased, and Linux installed to the MBR. Any ideas?

 

Thanks,

PJ

Share this post


Link to post
Share on other sites

I set my bios for boot order: 1st is cdrom, 2nd is ide primary, third is floppy. I just leave it like that because the bios will boot the computer via the first boot record it finds.

 

Take the first cd and boot from it, like you are going to install. At the splash screen, hit F1, type "rescue".

 

You will be presented with a menu. Choose to reinstall lilo at the mbr. Reboot, remembering to take the disk out of the drive, and you should be fine.

Share this post


Link to post
Share on other sites

Didn't work, same thing. This is the second time trying to reinstall it, are there any options I can try differently? I chose to install to MBR the last time, should I choose root partition next time? anything else I can try differently? I didn't run fdisk or format on the drive before doing any of this - make any difference?

 

Thanks again,

PJ

Share this post


Link to post
Share on other sites

If you do a search on the forum, you will find a much longer thread on this exact problem. According to that thread, the problem actually lies with LILO and not with your mandrake linux installation. Based on that, I would suggest reinstalling and using Grub as your bootloader instead of lilo. You may need to do an expert install to get this option.

 

If I can find the thread, I will post a link here.

Share this post


Link to post
Share on other sites

I always like to have a clean drive prior to an install, although theoretically it should make no difference. You could restore the mbr, reboot, and install again, but fuzzylizard is correct. There are several who have gone to grub because of what appears to be a lilo bug with certain hardware combos. You could do an upgrade at this point, only changing to grub, and the entire installation will remain intact.

Share this post


Link to post
Share on other sites

What's your /etc/lilo.conf file say? Does it match what you think it should be? Run the installer and do a custom install and stop at the partitioning screen. What does it look like? Is your lilo.conf stating lilo is on /hdb for example, when its now on hda? The bootloader has to be able to find the vmlinuz. Check your /etc/fstab file, does it look right? So on... :)

Share this post


Link to post
Share on other sites

If you reinstall MDL on a dual boot machine, you should choose MBR as location for Lilo. If not, MDL cannot repair MBR and you will see the "9" error. Same thing will happen when you change the boot method and do not repair the drive on the primary drive.

Share this post


Link to post
Share on other sites
Guest JohnM

PJ

 

I have had the same 99 error happen to me twice. I am using Windows 7 using an Asus mainboard. I found a workaround for this. If you use a program such as Norton Utilities put the installation disk into the CD/DVD player an reboot. If the system asks if you want to start the computer normally select yes. Take the disk out of the drive and reboot using CTRL+ALT+DEL. My computer then restarts normally. I hope that this has been of any help to you. John

Share this post


Link to post
Share on other sites

I doubt very much the CD thing would work with Linux - sounds more like a Windows idiosyncracy :lol2:

Share this post


Link to post
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.
Note: Your post will require moderator approval before it will be visible.

Guest
Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.

Loading...
Sign in to follow this  

×
×
  • Create New...