Jump to content
  • Announcements

    • spinynorman

      Mandriva Official Documentation

      Official documentation for extant versions of Mandriva can be found at doc.mandriva.com.   Documentation for the latest release may take some time to appear there. You can install all the manuals from the main repository if you have Mandriva installed - files are prefixed mandriva-doc.
    • paul

      Forum software upgrade   10/29/17

      So you may have noticed the forum software has upgraded !!!
      A few things that have changed. We no longer have community blogs (was never really used) We no longer have a portal page.
      We can discuss this, and decide whether it is needed (It costs money) See this thread: Here
hawklord

mdv2010.0 chown question (solved)

Recommended Posts

hi,

 

(sorry if this is in the wrong section, move at your will)

 

this isn't really a problem - at least i don't think it is, but its an annoyance

 

i'm running mandriva 2010.0 one, fully updated and working as it should,

 

the annoyance is i have a fixed ntfs storage drive which is owned by root, when i transfer file to it i get a message saying

 

"could not change permissions for /media/sdb2/any.file"

 

i have to click 'ok' for the message to go, its a bit annoying if i'm transfering, say, 10 files,

 

now as an experiment i opened konqueror as root and changed the owner manualy to a folder that is on sdb2 - wouldn't change,

so i typed in a root terminal

chown -r dave /media/sdb2/foldername

still no change,

 

do i need to change ownership of the whole partition ?, can i do it editing fstab ?

 

here is the line in my fstab

 

UUID=2A1C807A1C8042B5 /media/sdb2 ntfs-3g defaults,umask=000 0 0

 

i don't know whether this will help

 

[dave@localhost ~]$ cd /media/sdb2
[dave@localhost sdb2]$ ls -l
total 10456
drwxrwxrwx 1 root root     4096 2010-06-20 19:41
drwxrwxrwx 1 root root    16384 2010-06-19 00:04
[dave@localhost sdb2]$

 

(i've removed file names and file entries as they all say drwxrwxrwx 1 root root)

 

thanks for any help

Edited by hawklord

Share this post


Link to post
Share on other sites

I don't know how to bypass the messages as I have no ntfs partitions to test with but "chown" will not work on Windows file systems as they know nothing about unix ownership and permissions.

 

Ken

Share this post


Link to post
Share on other sites

hey guys,

 

thanks for the answers and info,

 

i seem to have found a fix, quite by accident - really

 

i tripple boot with pclinuxos as one of my boot options and was having a nosy around my root in pclos from mandriva,

i had a look in pclos's fstab and noticed that umask=000 was not in the entry for the ntfs partition and i booted into pclos to check for the info box when i copied a file across,

no box,

 

booted back into mandriva and removed the umask=000, ctrl, alt and backspace, logged back in - no change, still got the box

 

so i rebooted, copied a file across - bingo, no info box

 

case solved

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now

×