Jump to content
  • Announcements

    • spinynorman

      Mandriva Official Documentation

      Official documentation for extant versions of Mandriva can be found at doc.mandriva.com.   Documentation for the latest release may take some time to appear there. You can install all the manuals from the main repository if you have Mandriva installed - files are prefixed mandriva-doc.
    • paul

      Forum software upgrade   10/29/17

      So you may have noticed the forum software has upgraded !!!
      A few things that have changed. We no longer have community blogs (was never really used) We no longer have a portal page.
      We can discuss this, and decide whether it is needed (It costs money) See this thread: Here
boatman9

Monitor stuck in 800x600 mode

Recommended Posts

I'm working with a Magnavox 32MF339B/F7 TV/monitor attached to a computer running 2010.0 The video card is "nVidia Corporation NV18 [GeForce4 MX 440 AGP 8x] (rev a2)" with DVI and svideo outputs, using the nvidia proprietary driver. The monitor is capable of 1360x768 and works fine at that resolution in Windows, however in Linux the resolution seems to be stuck at 800x600. I want to change the display mode to 1360x768, have tried doing that using "Set up the graphical server" in MLCC but it remains in 800x600 mode.

 

Another strange thing is that xrandr does not show the usually outputs such as DVI-0, but instead shows the following:

 

Screen 0: minimum 800 x 600, current 800 x 600, maximum 800 x 600
default connected 800x600+0+0 0mm x 0mm
  800x600        60.0*

 

How should I begin to solve this problem? Is it all about changing settings in xorg.conf?

Share this post


Link to post
Share on other sites

Check to see if xorg.conf exists in /etc/X11 directory. If so, rename it to xorg.conf.old and reboot. Xorg doesn't need an xorg.conf nowadays, so maybe there is one there just a bit strangely configured.

 

Another thing you can do is switch to runlevel 3 and then do something like this:

 

Xorg -configure

 

and then copy the xorg.conf from the /root directory into /etc/X11 and see if it works any better. So in short, first step:

 

su (enter root password when prompted)
cd /etc/X11
mv xorg.conf xorg.conf.old

 

reboot, see if any better. If not:

 

su (enter root password when prompted)
init 3
Xorg -configure
cp /root/xorg.conf.new /etc/X11/xorg.conf

 

and reboot. I'm assuming that the new xorg.conf placed in root will be xorg.conf.new. Let us know how you get on.

Share this post


Link to post
Share on other sites

Check to see if xorg.conf exists in /etc/X11 directory. If so, rename it to xorg.conf.old and reboot. Xorg doesn't need an xorg.conf nowadays, so maybe there is one there just a bit strangely configured.

I deleted /etc/X11/xorg.conf and rebooted but did it did not even get to graphical mode. I will try the 'Xorg -configure' command next time I get to that computer, it's not at my usual location, I get there about every two days.

 

Another symptom that may be a helpful clue; at the grub menu where 'Help' 'Language' 'Kernel Option' should be displayed at the lower edge of the screen, those three choices are so low they are not visible, or maybe just the top of the letters can be seen. A similar problem exists at the top of the display as well as both right and left sides when in text mode. I don't see any way to solve that problem with xorg.conf because xorg.conf isn't run until after the grub menu has been displayed.

 

What about replacing the nvidia card with another brand? Do you think an ATI card might work OK?

Share this post


Link to post
Share on other sites

I think the reason you can't see the text is due to the change of resolution meaning you'd have to change the geometry settings on your monitor to reposition how the screen looks and/or change the height/width so that everything is visible. So that isn't a major problem.

 

Try the Xorg -configure as mentioned and let us know if it goes any better. It should start at least with a minimal config and a default driver like vesa or nv if an nvidia card. I wouldn't suggest an ATI ones since they are much more problematic than nvidia ones. So stick with the nvidia one, you're more likely to have this working far easier than an ATI one.

Share this post


Link to post
Share on other sites

I used 'Xorg -configure' to create xorg.conf.new (attached), copied it to /etc/X11/xorg.conf an rebooted. X did not start, there was an error message:

 

Fatal server error:

no screens found

 

After running Mandriva's X configuration tool I was able to recover to the 800x600 screen but still very much where I began, and still not seeing the usual screens when I run xrandr.

xorg.zip

Share this post


Link to post
Share on other sites

See if the following is any help.

 

http://burtonini.com/blog/computers/randr-2007-02-06-17-50

 

http://www.thinkwiki.org/wiki/Xorg_RandR_1.2

 

Three page guide: http://www.phoronix.com/scan.php?page=article&item=927

 

There is also something called monitor-edid. You might need to install that, or a newer version of it from backports. Don't know too much about it.

http://wiki.mandriva.com/en/Tools/monitor-edid

Share this post


Link to post
Share on other sites

I am familiar with xrandr but can't use it to any benefit in this case because the display output devices (such as VGA-0, DVI-0, S-video, etc.) have not been created. Compare the output of xrandr in my first post with that from your computer. The only output created is 'default' (800x600+0+0 0mm x 0mm).

 

Something has gone wrong in the process of creating VGA-0, DVI-0, S-video, etc. The graphics cards is an nvidia with DVI and S-video outputs, and is supposed to support at least two monitors, either 2 DVI or 2 VGA, or one of each, so xrandr should show at least VGA-0, VGA-1, DVI-0, DVI-1, S-video outputs.

Share this post


Link to post
Share on other sites

To enable S-Video (TV Out) on my system, I had to issue the following xrandr commands. I would imagine you need something similar (addmode and output).

 

$ xrandr --output S-video --set load_detection 1

$ xrandr --addmode S-video 800x600

$ xrandr --output S-video --mode 800x600

 

I also have the following in my /etc/X11/xorg.conf file.

Section "ServerLayout"
Identifier     "single head configuration"
Screen      0  "Screen0" 0 0
InputDevice    "Keyboard0" "CoreKeyboard"
EndSection

Section "InputDevice"
Identifier  "Keyboard0"
Driver      "kbd"
Option	    "XkbModel" "pc105+inet"
Option	    "XkbLayout" "us"
EndSection

Section "Device"
Identifier  "Videocard0"
Driver      "radeon"
       Option      "AccelMethod" "XAA"
Option	    "AGPMode" "4"
Option	    "GARTSize" "64"
Option	    "EnablePageFlip" "on"
Option	    "ColorTiling" "on"
Option	    "DPMS" "on"
EndSection

Section "Screen"
Identifier "Screen0"
Device     "Videocard0"
DefaultDepth     24
SubSection "Display"
	Viewport   0 0
	Depth     24
EndSubSection
EndSection

 

EDIT: The above xorg.conf was from Fedora 12 (previously edited Driver "radeon" to Driver "ati") with the same laptop I have Mandriva 2010 installed on. Below is the actual xorg.conf from Mandriva 2010 that I am using.

 

# File generated by XFdrake (rev )

# **********************************************************************
# Refer to the xorg.conf man page for details about the format of
# this file.
# **********************************************************************

Section "ServerFlags"
   Option "DontZap" "False" # disable <Ctrl><Alt><BS> (server abort)
   #DontZoom # disable <Ctrl><Alt><KP_+>/<KP_-> (resolution switching)
   AllowMouseOpenFail # allows the server to start up even if the mouse does not work
EndSection

Section "Module"
   Load "dbe" # Double-Buffering Extension
   Load "v4l" # Video for Linux
   Load "extmod"
   Load "glx" # 3D layer
   Load "dri" # direct rendering
EndSection

Section "Monitor"
   Identifier "monitor1"
   VendorName "Generic"
   ModelName "Flat Panel 1400x1050"
   HorizSync 28.8-90
   VertRefresh 60

   # TV fullscreen mode or DVD fullscreen output.
   # 768x576 @ 79 Hz, 50 kHz hsync
   ModeLine "768x576"     50.00  768  832  846 1000   576  590  595  630

   # 768x576 @ 100 Hz, 61.6 kHz hsync
   ModeLine "768x576"     63.07  768  800  960 1024   576  578  590  616
EndSection

Section "Device"
   Identifier "device1"
   VendorName "ATI Technologies Inc"
   BoardName "ATI Radeon X1950 and earlier"
   Driver "ati"
   Option "AccelMethod" "XAA"
   Option "AGPMode" "4"
   Option "GARTSize" "64"
   Option "EnablePageFlip" "on"
   Option "ColorTiling" "on"
   Option "DPMS"
   Option "set load detection" "1"
EndSection

Section "Screen"
   Identifier "screen1"
   Device "device1"
   Monitor "monitor1"
   Subsection "Display"
           Depth    24
    Modes    "1400x1050" "1024x768" "800x600"
           # Here you can set virtual screen size:
           Virtual 2800 1050
   EndSubsection
EndSection

Section "ServerLayout"
   Identifier "layout1"
   Screen "screen1"
EndSection

Edited by David Batson

Share this post


Link to post
Share on other sites

Thanks to both of you for your advice and the research you've done on this problem. I have been studying the xorg.conf documentation and will try creating a custom xorg.conf file. I will post here when I find a working solution.

Share this post


Link to post
Share on other sites

Well, I worked on this problem again for a couple hours today. The problem is still affecting my friend's computer, stuck at 800x600, and seems to be due to the fact that none of the ModeLine modes under Section "Monitor" (in xorg.conf) actually work, meaning they don't appear as mode choices when I run xrandr. To make matters worse the TV's EDID data seems to be invalid; I used "get-edid | parse-edid" to read the EDID data and got some message that said not to trust the data, also the data looked like it was incorrect.

 

I have two computers of my own, a laptop and a desktop. My laptop acts the same as my friend's machine, meaning ModeLines added under Section "Monitor" don't appear in xrandr output. In my desktop I can add modes by adding ModeLine statements under Section "Monitor", the modes then appear as mode choices in xrandr. I suspect the later situation is the way it's supposed to work.

 

Anyone know how I can make ModeLine statements work as they should? This seems like a big bug in the Xorg package, or maybe there's something I've overlooked.

Share this post


Link to post
Share on other sites

Just speculation. What if you add nomodeset to the kernel parameter boot line? This would disable KMS (kernel mode setting).

 

Was /etc/X11/xorg.conf existing from the initial install or was something like system-config-display (Fedora) used to create it?

Share this post


Link to post
Share on other sites
Was /etc/X11/xorg.conf existing from the initial install or was something like system-config-display (Fedora) used to create it?

On my friend's computer with the 1360x768 TV, xorg.conf was created during installation using an analog VGA monitor, later an AGP video card was added and the monitor was replaced by the 1360x768 TV.

 

The introduction of the xorg.conf man page states;

Xorg supports several mechanisms for supplying/obtaining configuration and run-time parameters: command line options, environment variables, the xorg.conf configuration file, auto-detection, and fallback defaults. When the same information is supplied in more than one way, the highest precedence mechanism is used.

 

After reading that, I suspect the xorg.conf file has a fairly low priority for supplying/obtaining configuration and run-time parameters, relative to the other mechanisms mentioned in the man page. I've already looked at the man pages for xserver and xorg. Do you know where to find details about how to change the priorities of the configuration mechanisms mentioned?

Edited by boatman9

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now

×