Jump to content

Okular - printing problems [solved]


Recommended Posts

I'm running Mandriva 2010 Free 64 bit version.


I'm having problems trying to print from Okular. The first problem, any time I try to print a PDF file, the print dialogue always comes up setting the printer to A4 paper size. I can change it to letter, and some times the files will print O.K. There doesn't seem to be a way to configure Okular to set the paper size to letter ( 8.5 x 11 ). This is more of a pain than anything else. Is there a way to set the paper size, so I don't have to change it every time I use the Okular?


Second problem. I said sometimes it will print. I created a PDF file with my HP flatbed scanner. I run the scanner under V-box, since there is no linux driver for the HP G4010. I then copied the file to my home partition, and tried to print. As soon as I ( changed paper size first) tried to print, the red paper light on my Brother HL2040 turns on. Paper never moves, the red light is on.


I have seen the same problem with files I did not create. I tried several times, and verified there was no paper jam.


Because I had to get that file printed, I went back into v-box, and attached the printer to v-box. I opened an old version of Acrobat reader under XP, clicked print, and the file printed on the Brother.


From this I conclude my printer is OK, it prints everything else. I strongly suspect the PDF file is O.K. since I can view it in Okular, and on windbloze, and print from XP.


I would prefer not to install Acrobat reader for linux, since there doesn't seem to be a Mandriva file in the repos and I don't like installing software ( its a 60 meg file ) not build for my system.


I looked at Okular, it has a setting for backends. It lists Ghostscript. I'm guessing now, that Ghostscript does the printing. Can any one confirm this? If that is the case, is there a way to change the default paper size in Ghostscript?


Is the printing issue got something to do with Ghostscript?


Is there a better linux program to install to handle PDF files? Your thoughts.

Link to comment
Share on other sites

I think I have solved this problem. For anyone interested, the problem appears to have been the default printer settings in cups. The paper size for the HL2040, the system default printer was set to A4. I changed that to letter. Now when I open a file in Okular, and try to print, it is set to letter as the paper size. I now no longer have to change that value. The surprise for me is the file I could not print before now prints without problems.


I have to assume other printing applications like Open Office were setting the correct paper size and over riding the A4 size. I never had a problem with OO with the paper size in Cups set wrong. Hope this experience helps someone else...

Link to comment
Share on other sites

  • 2 weeks later...

Well, I had the need to print some PDF files created by the bank. They would not print with Okular. I simply don't know why. The symptoms, the file got sent to cups. Nothing happened on the printer. I looked in cups, and according to cups the job completed.


I installed Acrobat Reader. I downloaded this -->AdbeRdr9.3.2-1_i486linux_enu.rpm from Freshmeat, and installed it using urpmi. I can now open the PDF's from the bank, and print them. There has to be a problem somewhere, but I don't know where. For now I'll leave Acroread installed and use it.

Link to comment
Share on other sites

  • 2 weeks later...

I've had problems with some pdf's before, and they could only be viewed correctly in Adobe Reader.


The strange thing for this problem is, Okular can view the documents, but can not send them to the printer. Adobe can do both.


As a work around, I installed Adobe so I can print pdf documents.

Link to comment
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.
Note: Your post will require moderator approval before it will be visible.

Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.


  • Create New...