MandrivaUsers.org : Laptop shutdown problem - Mandriva 2007.0 - MandrivaUsers.org

Jump to content

Page 1 of 1
  • You cannot start a new topic
  • You cannot reply to this topic

Laptop shutdown problem - Mandriva 2007.0 System freezes after "Shutdown" or "halt"

#1 User is offline   nik_123 

  • New Here
  • Group: New here
  • Posts: 3
  • Joined: 01-December 09

Posted 01 December 2009 - 10:51 AM

Hallo all here! I got the following problem : I have an old laptop - Intel Pentium 2 celeron- 360 mhz, 128 MB RAM, Video Voodoo3fx - 4 MB video memory. On that system I use Mandriva 2007, kernel 2.6.17-17, GNOME 2.16. Everything seems to be OK, but after selecting "Shutdown" from GNOME menu or just typing "halt" as root in the terminal, system starts to halting, but after the message " System halted" laptop just freezes, doesn't turn off actually- I have to push the Power button to shut off the power really. On the same laptop, I have used Mandriva 2009.0 and I haven't got that problem- but mandi 2009 is too heavy, 2007 works quite faster on that machine and I would like to use 2007.0. The same problem I have with 2007.1 too. Can anyone help me? Thanks in advance.
0

#2 User is offline   SilverSurfer60 

  • Mandriva Guru
  • Group: Members
  • Posts: 1,545
  • Joined: 14-June 05

Posted 01 December 2009 - 11:57 AM

If it's any consolation I have the exact same problem on an old Toshiba. It won't even reboot ever since 10.6, or something like that. I never got to the root cause and have got used to pushing the button.
To whom should I go for self help?
No point in being pessimistic, it wouldn't work anyway
Got a new car for the wife : A great swap
0

#3 User is offline   ianw1974 

  • Platinum
  • View blog
  • Group: Admin
  • Posts: 14,047
  • Joined: 09-March 05

Posted 01 December 2009 - 09:24 PM

Are the acpi packages installed? I had problems with machines not shutting down because of missing acpi.

Or maybe older machines require apm packages instead.
Ian Walker

Light travels faster than sound. This is why some people appear bright until you hear them speak.........

Posted Image2 x systems installed with Ubuntu 14.04 x86_64 (Laptop and Desktop)
Posted Image1 x systems installed with Gentoo x86_64 (Desktop)

My Linux Solutions | Linux Systems Limited
0

#4 User is offline   nik_123 

  • New Here
  • Group: New here
  • Posts: 3
  • Joined: 01-December 09

Posted 01 December 2009 - 09:30 PM

[root@localhost ~]# urpmi acpi
The package(s) are already installed
[root@localhost ~]#
acpi is installed. What is apm, and how to try it?

By the way, Mandriva 2009 also contains acpi, but with it the laptop halts normally.

This post has been edited by nik_123: 01 December 2009 - 09:31 PM

0

#5 User is offline   nik_123 

  • New Here
  • Group: New here
  • Posts: 3
  • Joined: 01-December 09

Posted 02 December 2009 - 08:59 AM

apmd is also on and starts during boot. Any ideas? Why the laptop halts normally with Mandriva 2009, but freezes during "halt" with 2007.0 ?
0

#6 User is offline   ianw1974 

  • Platinum
  • View blog
  • Group: Admin
  • Posts: 14,047
  • Joined: 09-March 05

Posted 02 December 2009 - 07:18 PM

I had similar happen on an old machine of mine when I had Mandriva 2007 and found in the end my BIOS was not in a good state. I re-flashed it and it started working again after that. Incidently, when I upgraded the BIOS it was working fine, but then I lost sound, so I downgraded back to the version I had, and then it still powered off OK and sound was working again.

It might not be the same issue, but I also found that if I installed other distros, it was working fine, just Mandy was a problem. I did have a bug open for it ages ago, but then I solved it when flashing the BIOS.

What you can try to do to see if you do have similar problem to me, is open a console window, su to root privileges, and then type:

poweroff


and see if it shuts down correctly? halt wouldn't work for me, but poweroff would.
Ian Walker

Light travels faster than sound. This is why some people appear bright until you hear them speak.........

Posted Image2 x systems installed with Ubuntu 14.04 x86_64 (Laptop and Desktop)
Posted Image1 x systems installed with Gentoo x86_64 (Desktop)

My Linux Solutions | Linux Systems Limited
0

#7 User is offline   Greg2 

  • 45% Platinum
  • Group: Global Moderator
  • Posts: 2,485
  • Joined: 06-April 04

Posted 02 December 2009 - 09:59 PM

I had that problem with a P2- 333 mhz, using an older 2.6.xx kernel. I added
pci=noacpi acpi=off
as boot parameters, and it worked for me.
0

#8 User is offline   ianw1974 

  • Platinum
  • View blog
  • Group: Admin
  • Posts: 14,047
  • Joined: 09-March 05

Posted 03 December 2009 - 07:01 AM

Ah, greg2 you reminded me of this. I was using this at one point too albeit without the pci=noacpi, only the additional extra I had on that line was:

acpi=off apm=poweroff


so that acpi was disabled, and apm would power the machine off. It didn't always work for me though, but I found that the problem was due to the halt command, because poweroff would work for me everytime. Sadly, it meant I'd have to keep opening a console window as root to do it.
Ian Walker

Light travels faster than sound. This is why some people appear bright until you hear them speak.........

Posted Image2 x systems installed with Ubuntu 14.04 x86_64 (Laptop and Desktop)
Posted Image1 x systems installed with Gentoo x86_64 (Desktop)

My Linux Solutions | Linux Systems Limited
0

Share this topic:


Page 1 of 1
  • You cannot start a new topic
  • You cannot reply to this topic

1 User(s) are reading this topic
0 members, 1 guests, 0 anonymous users