MandrivaUsers.org : New Linux user. Firefox 3 displays awful fonts - MandrivaUsers.org

Jump to content

Page 1 of 1
  • You cannot start a new topic
  • You cannot reply to this topic

New Linux user. Firefox 3 displays awful fonts

#1 User is offline   osom 

  • New Here
  • Group: Members
  • Posts: 19
  • Joined: 10-November 08

Posted 05 December 2008 - 08:00 PM

Hi, I am new at Linux, using Mandriva 2009 with Gnome, KDE and Xfce installed together.

Firefox displays horrible fonts in the 3 systems. I have Firefox with the default fonts. I have tried to change them manually and didn't get better. I have FreeType installed plus adjusted my Mandriva for the best font quality display in the Font Manager. I have all the Windows fonts too, a total of 100 fomnts installed.

Firefox looks absolutely horrible. The fonts not only look ugly but the sizes are absurd. Usually too small, unreadable many times, but the size of a same site changes every day...

Any idea to improve this?

Thanks


[moved from Software by spinynorman]
0

#2 User is offline   tux99 

  • Emperor Penguin
  • Group: Members
  • Posts: 611
  • Joined: 21-September 08

Posted 06 December 2008 - 01:05 PM

Fonts look good on my Mandriva 2009, I didn't do anything special, default fonts and default config, maybe all those extra fonts you installed caused this, or did you see it since before installing them?
Have you tried creating a new user and starting Firefox as that user, to make sure it's not something in your Firefox config?
It could also be a X windows dpi setting problem, do a:
grep -i dpi /var/log/Xorg.0.log

and post the output you get.
Maybe also post a screenshot of firefox with the horrible fonts, to show us what you mean.
Linux user since 1995 (Slackware 2.2), Mandrake/Mandriva user since 6.0, Redhat Certified Engineer (RHCE)
>>>LinuxTECH.NET<<<
Linux - Life in the Open without Walls or Windows
0

#3 User is offline   medo3891 

  • frequent
  • Group: Members
  • Posts: 232
  • Joined: 21-February 08

Posted 10 December 2008 - 03:57 AM

You might consider enabling Antialiasing in the kde control centre, also try changing the hinting style to full, you can also try increasing the DPI of the system.
0

#4 User is offline   theYinYeti 

  • Mandriva Guru
  • Group: Members
  • Posts: 2,147
  • Joined: 23-September 02

Posted 10 December 2008 - 08:01 AM

Is your display a flat panelĀ ? If so, is it set to its native resolutionĀ ?

Yves.
sedentaire: C2DuoE4300, 3GB, 1TB+NFS, Arch Linux, k3.x, Compiz
joli: Dell Inspiron1501, Arch Linux, k3.x, Gnome 3
sphinx2: eSata SheevaPlug, 512MB, 2GB SDcard, Debian Wheezy, k3.2
nomade: P166MMX, 32MB, 2GB, Deb3.1, k2.4.x, IceWM|XDMCP
work: Samsung(ath wifi), Mdv2009.0, k2.6.x, Gnome(rox)
sphinx: VIA1GHz, 256MB, 512MB USBstick, Debian Lenny, k2.6.x
salon: VIA1GHz, 256MB, 512MB USBstick, saa7134 PCTV Stereo, GeeXboX
0

#5 User is offline   David Batson 

  • Awesome
  • Group: Members
  • Posts: 408
  • Joined: 22-January 08

Posted 10 December 2008 - 01:01 PM

See if the following link gives you some useful tips. http://avi.alkalay.n...howto/Font.html
0

Share this topic:


Page 1 of 1
  • You cannot start a new topic
  • You cannot reply to this topic

1 User(s) are reading this topic
0 members, 1 guests, 0 anonymous users