MandrivaUsers.org : mandriva 2008.0 will not mount usb drive [solved] - MandrivaUsers.org

Jump to content

Page 1 of 1
  • You cannot start a new topic
  • You cannot reply to this topic

mandriva 2008.0 will not mount usb drive [solved]

#1 User is offline   sermat 

  • New Here
  • Group: Members
  • Posts: 46
  • Joined: 21-November 06

Posted 19 December 2007 - 11:49 PM

Hi to all. Just installed 2008.0 and it looks excellent. The only thing so far is that when I plug in my USB hard drive, a little window pops up telling me "Permission denied". But when I use command line to mount this drive it mounts perfectly.
Many thanks,
serge.

This post has been edited by sermat: 22 December 2007 - 12:39 AM

0

#2 User is offline   scarecrow 

  • Platinum
  • Group: Platinum
  • Posts: 5,157
  • Joined: 16-February 05

Posted 20 December 2007 - 05:42 AM

Rightclick the desktop HD icon, and untick the "mount as user" option. Now you should be able to mount it by clicking on it...
0

#3 User is offline   sermat 

  • New Here
  • Group: Members
  • Posts: 46
  • Joined: 21-November 06

Posted 20 December 2007 - 03:44 PM

Hi scarecrow: I'm sorry for being an idiot here, but when I plug in the USB drive, the only thing that happens is that a window pops up, telling me: "A new medium has been detected. What do you want to do?" So I'm not sure how do I do what you suggested me to do?

Again, sorry for my lack of knowledge here.
serge.
0

#4 User is offline   pmpatrick 

  • Mandriva Guru
  • Group: Members
  • Posts: 1,862
  • Joined: 23-September 02

Posted 20 December 2007 - 04:31 PM

How is the drive formatted, eg FAT, ext3, reiserfs?
0

#5 User is offline   sermat 

  • New Here
  • Group: Members
  • Posts: 46
  • Joined: 21-November 06

Posted 20 December 2007 - 04:44 PM

ext3
0

#6 User is offline   pmpatrick 

  • Mandriva Guru
  • Group: Members
  • Posts: 1,862
  • Joined: 23-September 02

Posted 20 December 2007 - 08:51 PM

Mount the device from the command line. Determine the mount point by running this if you don't already know it:

$ mount

Then as root run:

# chmod -R 777 <mount point>

That should give the world rwx permissions on the drive. Then to safely remove the device run:

# sync
# umount <mount point>

and physically remove the drive. Try reinserting it and see if you still get the permission problem.
0

#7 User is offline   sermat 

  • New Here
  • Group: Members
  • Posts: 46
  • Joined: 21-November 06

Posted 20 December 2007 - 11:08 PM

thanks pmpatrick: yes, I followed your instructions to the letter, and no change; i.e., I still get "permission denied" notice.
BUT, I do not want to bug you for help on this item any more. As I mentioned, I can mount my USB hard drive from the command line just fine. I'm just a bit surprised that Mandriva would exhibit this kind of negative behavior. Other distros I tried on this same PC and USB hard drive had no problems mounting it by just plugging the drive in.
0

#8 User is offline   AussieJohn 

  • MAGEIA votary
  • Group: Members
  • Posts: 3,119
  • Joined: 25-August 03

Posted 21 December 2007 - 11:24 PM

You say your flash drive is formatted ext3. This means you formatted it on a linux machine. It is likely that in doing so you set it up with root permissions only, hence you accessing only by root in Konsole.

Open MCC and go to the section for mounting partitions. You will see it there as an additional drive to your hard drives.
Click on it as seen in the top tabs and then on the flash drives partition. Then click on mountpoint and give it a name of your choice but make sure it is /name and not just name.
Click okay then Mount and then Done. Click Yes to the first of the popup messages you get (one at the beginning and one at the end) and no to the second one.

Now open a console and type in kdesu konqueror and click enter. It will ask for your root password so type it in (no visible text) then enter again. After a moment or two Konqueror will open but now it is in root mode. Type a / and enter the selected name you gave to your flash drive to see that anything you have on it can be seen. If ok then go back, do not close.
This time right click on your flash drive icon and select permissions there you can change the permissions as you want. Be sure to put a dot in the bottom left spot so all items in the drive are given the same permissions when you add data later.

I recommend going back to the MCC partition section again (with the flash drive still in place) and this time selecting Unmount and then mountpoint again and deleting the /name so it is now blank then ok then Done. Go back to your still root enabled konqueror. Find the flash drive name and right click and select properties on it to make sure it is only 1 to 5 kbs. If it is then it is safe to right click on it again and delete it.

I hope this helps. As you can see, the problem is not with Mandriva but with how you set up your flash drive originally.
How do I know ???. I have two flash drives and one is ext3 and the other is fat32 as originally set.
When I did the ext3 repartioning I already new that permissions had to be set correctly so I never had any unexpected problems.

One further word of advice. Before removing the Flash drive at anytime always select Remove Safely from the right click menu on the icon.


Cheers. John.
The Computer future is here TODAY ..... Mageia-4, KDE4, Dolphin, K3B, Grip, Audacious, Totem, Kaffeine, SVLC, Kmail, Libre-Office, Scribus, XSane, Gimp, OpenShot, FireFox, FlightGear, Filelight, Gwenview, Geeqie, GoogleEarth, Skype, Pysol-FC.

Corsair Obsidian 750D Full Tower Case (with full Window), AMD Athlon-FX8120 8-Core 3.1Ghz Processor, Gigabyte GA-990FXA-UD3 USB3 rev.4 MainBoard, Gigabyte Nvidia-GeForce-9600-GT VideoCard, 16Gb Corsair "Vengeance" DDR3 Memory, 1 x Corsair 240Gb SSD Neutron Hard Drive, WD SATA-II 500GB 16mb HDD, 2 x LG Sata DVD-R/RW Burners, LG 27" LED LCD HDMI Monitor, Hewlitt-Packard PhotoSmart 6510 Printer, APC BackUPS-CS-650 UPS, Corsair HX650W Power Supply, Vantec Dual HDD Docking Station SATA-USB3.

ADSL-2+ Internet Connection_50Gb (Bigpond)

JOHN. (79+yrs, Young) Registered LINUX user #318452
0

#9 User is offline   sermat 

  • New Here
  • Group: Members
  • Posts: 46
  • Joined: 21-November 06

Posted 22 December 2007 - 12:27 AM

AussieJohn: Thank you so much for taking time to give me such detailed instructions - Very kind of you. OK, just before seeing your reply, I was "fooling around" with couple of things on my own, and here is what solved the problem (well, I did a number of things, and maybe something else contributed to the solution also, but the following is the "thing" that really did it):

Open MCC -> Local Disks -> Mange disk partitions, then open the sda (my USB hard drive) tab, then click on Toggle to Expert Mode button and then click on Options button and tick the "user" check box (this allows an ordinary user to mount the file system). And that was it - it WORKS now.

Thanks again John for your help.
Best regards to all, and BIG CONGRATULATIONS TO MANDRIVA for an excellent product.
serge.
0

#10 User is offline   AussieJohn 

  • MAGEIA votary
  • Group: Members
  • Posts: 3,119
  • Joined: 25-August 03

Posted 22 December 2007 - 01:40 AM

Sounds good and simple. Noted for future reference. :thumbs:/>

No matter how much you learn about Mandriva you will always learn something new from some elses experience. :D/>

Cheers. John.
The Computer future is here TODAY ..... Mageia-4, KDE4, Dolphin, K3B, Grip, Audacious, Totem, Kaffeine, SVLC, Kmail, Libre-Office, Scribus, XSane, Gimp, OpenShot, FireFox, FlightGear, Filelight, Gwenview, Geeqie, GoogleEarth, Skype, Pysol-FC.

Corsair Obsidian 750D Full Tower Case (with full Window), AMD Athlon-FX8120 8-Core 3.1Ghz Processor, Gigabyte GA-990FXA-UD3 USB3 rev.4 MainBoard, Gigabyte Nvidia-GeForce-9600-GT VideoCard, 16Gb Corsair "Vengeance" DDR3 Memory, 1 x Corsair 240Gb SSD Neutron Hard Drive, WD SATA-II 500GB 16mb HDD, 2 x LG Sata DVD-R/RW Burners, LG 27" LED LCD HDMI Monitor, Hewlitt-Packard PhotoSmart 6510 Printer, APC BackUPS-CS-650 UPS, Corsair HX650W Power Supply, Vantec Dual HDD Docking Station SATA-USB3.

ADSL-2+ Internet Connection_50Gb (Bigpond)

JOHN. (79+yrs, Young) Registered LINUX user #318452
0

#11 User is offline   Borget 

  • New Here
  • Group: New here
  • Posts: 1
  • Joined: 08-February 08

Posted 08 February 2008 - 06:11 PM

Thanks, i had the same problem. This solved it.
0

#12 User is offline   L_Baum 

  • New Here
  • Group: New here
  • Posts: 1
  • Joined: 23-November 08

Posted 23 November 2008 - 02:23 PM

Coming from Ubuntu, I did not pay attention to the MCC (Mandriva Control Center), but it works well.
I could not write to my PCMCIA-Flash-drive, though I have mounted a lot of drives already by changing the fstab. The MCC solved the problem.

Thank you.
0

#13 User is offline   sermat 

  • New Here
  • Group: Members
  • Posts: 46
  • Joined: 21-November 06

Posted 23 November 2008 - 09:19 PM

Glad it worked.
serge.
0

#14 User is offline   jeevanism 

  • New Here
  • Group: Members
  • Posts: 11
  • Joined: 06-October 10

Posted 06 October 2010 - 12:21 PM

View Postsermat, on 22 December 2007 - 12:27 AM, said:

Open MCC -> Local Disks -> Mange disk partitions, then open the sda (my USB hard drive) tab, then click on Toggle to Expert Mode button and then click on Options button and tick the "user" check box (this allows an ordinary user to mount the file system). And that was it - it WORKS now.


wowow..it worked..yes..even Ubuntu users are running hard for it.. enormous command line and chmod plays./.MCC done is it easy...
I dont understand why Ubuntu is the number one Distro in hitting,ppl are crazy..
--JeevanisM--
Through Science, to Freedom; Through Freedom, to humanity!!
0

Share this topic:


Page 1 of 1
  • You cannot start a new topic
  • You cannot reply to this topic

1 User(s) are reading this topic
0 members, 1 guests, 0 anonymous users