MandrivaUsers.org : Can Mandriva 2008 write to NTFS partitions? - MandrivaUsers.org

Jump to content

  • 2 Pages +
  • 1
  • 2
  • You cannot start a new topic
  • You cannot reply to this topic

Can Mandriva 2008 write to NTFS partitions? [solved]

#1 User is offline   darkscot 

  • casual
  • Group: Members
  • Posts: 94
  • Joined: 05-December 06

Posted 10 October 2007 - 09:05 AM

Hello!
I have been using Sabayon for quite a while but for various reasons want to go back to a more 'conventional' distro. One of the features of Sabayon is that it can read AND write to NTFS partitions, can Mandriva 2008 do the same?

Edit: Actually what I meant to ask was can Mandriva 2008 write to NTFS by default or do you have to intall NTFS-3g or similar?
0

#2 User is offline   spinynorman 

  • Not a Mandriva Guru
  • View blog
  • Group: Admin
  • Posts: 4,221
  • Joined: 04-June 03

Posted 10 October 2007 - 09:21 AM

See the release notes...
Posted Image Track Bugs at Bugzilla Posted Image
ASUS Terminator P4 1.7 GHz; 256MB DDR RAM; 40GB; 7200 rpm U-DMA ATA-100 IDE HD; Hansol H530 TFT monitor; 16x48 DVD; 40x12x48 CD-RW; Netgear DG834G; Epson Stylus C62; Mandriva 2008.1
0

#3 User is offline   darkscot 

  • casual
  • Group: Members
  • Posts: 94
  • Joined: 05-December 06

Posted 10 October 2007 - 09:52 AM

View Postspinynorman, on Oct 10 2007, 10:21 AM, said:

See the release notes...

Aaaaaaah! Release notes! I read the release tour, and there is nothing about this in there! :rolleyes:/>

http://wiki.mandriva...iva/2008.0/Tour

Anyway, thanks for pointing me in the right direction!

This post has been edited by darkscot: 10 October 2007 - 09:55 AM

0

#4 User is offline   kurt_ram 

  • New Here
  • Group: Members
  • Posts: 12
  • Joined: 14-October 07

Posted 14 October 2007 - 03:17 AM

Did those instructions work for you?

I couldn't get it to work. This is my fstab

/dev/hdb2 / ext3 relatime 1 1
/dev/hdb10 /home ext3 relatime 1 2
/dev/cdrom /media/cdrom auto umask=0022,users,iocharset=utf8,noauto,ro,exec 0 0
/dev/cdrom2 /media/cdrom2 auto umask=0022,users,iocharset=utf8,noauto,ro,exec 0 0
/dev/fd0 /media/floppy auto umask=0022,users,iocharset=utf8,noauto,exec,flush 0 0
/dev/hda1 /mnt/win_c ntfs umask=0022,nls=utf8,ro 0 0
/dev/hdb5 /mnt/win_c2 ntfs umask=0022,nls=utf8,ro 0 0
/dev/hda5 /mnt/win_d ntfs umask=0022,nls=utf8,ro 0 0
/dev/hdb6 /mnt/win_d2 vfat umask=0000,iocharset=utf8 0 0
/dev/hda6 /mnt/win_e vfat umask=0022,iocharset=utf8 0 0
/dev/hdb7 /mnt/win_e2 vfat umask=0022,iocharset=utf8 0 0
/dev/hda7 /mnt/win_f vfat umask=0000,iocharset=utf8 0 0
/dev/hdb8 /mnt/win_f2 ntfs-3g umask=0000,nls=utf8,ro 0 0
/dev/hda8 /mnt/win_g vfat umask=0022,iocharset=utf8 0 0
/dev/hda9 /mnt/win_h ntfs-3g umask=0000,nls=utf8,ro 0 0
none /proc proc defaults 0 0
/dev/hda10 swap swap defaults 0 0
/dev/hdb9 swap swap defaults 0 0


When I try to create a new file in /mnt/win_h, /mnt/win_f2, /mnt/d2 or /mnt/f, it fails with an error message eventhough umask has been set to 0000.

Any help?
= Kurt =
Posted Image Posted Image Posted Image
0

#5 User is offline   kurt_ram 

  • New Here
  • Group: Members
  • Posts: 12
  • Joined: 14-October 07

Posted 14 October 2007 - 03:40 AM

I think I figured out what my mistake was. I forgot to change "ro" to "rw". I did this for the folders that I want write access & added "users" flag to the options for those mount points and now I'm able to create new folders in these partitions.

Thanks
= Kurt =
Posted Image Posted Image Posted Image
0

#6 User is offline   darkscot 

  • casual
  • Group: Members
  • Posts: 94
  • Joined: 05-December 06

Posted 31 October 2007 - 10:11 PM

View Postkurt_ram, on Oct 14 2007, 03:17 AM, said:

Did those instructions work for you?

I got them to work eventually. You have to reboot for the changes to take effect, it is not enough to log out of X.

Here is the relevent line from my fstab:
/dev/sdb3 /media/hd5 ntfs-3g umask=0,user,nls=utf8,sync 0 0

0

#7 User is offline   menendez 

  • casual
  • Group: Members
  • Posts: 92
  • Joined: 14-August 07

Posted 02 November 2007 - 02:37 PM

I followed the release note instructions. Got no errors and restarted. But it doesn't seem to mount as I cannot see it from konqueror, even after I go into the Mandriva Control Center and mount it.
Here is the relevent line from my fstab:

/dev/hda1 /media/hd ntfs-3g umask=0022,nls=utf8,sync 0 0

0

#8 User is offline   menendez 

  • casual
  • Group: Members
  • Posts: 92
  • Joined: 14-August 07

Posted 02 November 2007 - 02:45 PM

I also tried unmask=0
That didn't work either.

I reverted back to a regular read-only NTFS install

This post has been edited by menendez: 02 November 2007 - 05:28 PM

0

#9 User is offline   scoonma 

  • Awesome
  • Group: Members
  • Posts: 458
  • Joined: 30-June 06

Posted 07 November 2007 - 01:57 AM

Hm, did you enter "unmask" or "umask"? Only the latter would be correct... ;)/>
"The rich man considers everything as buyable, since he knows himself as the power from the specialty of his self-awareness. Thus wealth can lead to the same mockery and gracelessness to which indigent ragtag goes." "Poverty itself does not make anyone raffish."

G.W.F. Hegel
0

#10 User is offline   scarecrow 

  • Platinum
  • Group: Platinum
  • Posts: 5,157
  • Joined: 16-February 05

Posted 07 November 2007 - 02:24 PM

It has been already said THOUSANDS of times, but here we go again:
For a local NTFS partition, something like
/dev/sdb1 /media/winxp ntfs-3g locale=el_GR.UTF-8,defaults 0 1

in fstab should be enough to handle this partition as read/write. Of course you should substitute the "el_GR.UTF8" argument I used with your actual locales, or omit this argument completely if the windoze locale happens to be the same as the Linux one!
For EXTERNAL harrddisk things it's a tad more difficult: First you must tell hal to mount NTFS parttions with ntfs-3g and not ntfs. Here's a rule which does just that:
<?xml version="1.0" encoding="UTF-8"?>
<deviceinfo version="0.2">
<!-- mount ntfs volume with the ntfs-3g driver to enable write support -->
	<device>
		<match key="volume.fstype" string="ntfs">
			<match key="@block.storage_device:storage.hotpluggable" bool="true">
				<merge key="volume.fstype" type="string">ntfs-3g</merge>
				<merge key="volume.policy.mount_filesystem" type="string">ntfs-3g</merge>
			</match>
		</match>
	</device>
</deviceinfo>

Save tha above as say "001-ntfs-policy.fdi" and copy it to your hal policies directory (for my distro: /etc/hal/fdi/policy ). Now restart HAL and udev, and you are ready.
If the removable drive uses a different locale than the system one, then you have to do some more work:
Delete /sbin/mount.ntfs-3g (which is just a symbolik link, so you aren't deleting anything) and replace it with a simple script:
#!/bin/bash
/bin/ntfs-3g -o locale=el_GR.UTF-8 $1 $2

(replace again el_GR.UTF-8 with the actual locale your NTFS harddisk is using). Omitting the last step ALL the files with names coded in a different locale than your current one will not be visible, at all.
PS:Dont forget to flag that last script as executable before copying it to /sbin

This post has been edited by scarecrow: 19 November 2007 - 09:30 AM

0

#11 User is offline   darkscot 

  • casual
  • Group: Members
  • Posts: 94
  • Joined: 05-December 06

Posted 07 November 2007 - 06:52 PM

Now compare that with how it is done in PCLinuxOS!

http://images.howtof...pclinuxos/9.jpg

Given the choice, I know which one the average newbie would choose!

This post has been edited by darkscot: 07 November 2007 - 09:01 PM

0

#12 User is offline   scoonma 

  • Awesome
  • Group: Members
  • Posts: 458
  • Joined: 30-June 06

Posted 08 November 2007 - 03:10 AM

? 403: access forbidden...
"The rich man considers everything as buyable, since he knows himself as the power from the specialty of his self-awareness. Thus wealth can lead to the same mockery and gracelessness to which indigent ragtag goes." "Poverty itself does not make anyone raffish."

G.W.F. Hegel
0

#13 User is offline   scarecrow 

  • Platinum
  • Group: Platinum
  • Posts: 5,157
  • Joined: 16-February 05

Posted 08 November 2007 - 04:51 PM

View Postdarkscot, on Nov 7 2007, 09:52 PM, said:

Now compare that with how it is done in PCLinuxOS!


Indeed, my 12-year old daughter uses PCLinuxOS and their method (perhaps not the same as in your snapshot... :P/> ).
By the way, the easiest solution is patching the kernel so that the ntfs module would be substituted by ntfs-3g... factly this is the approach some recovery and forensics liveCD's are using. But patching the kernel with a driver that depends on an external module (fuse) is clearly enough a VERY dirty solution, which few (very few) distros will adopt. Still, nobody will ever prevent you from doing so, actually it's rather easy.
But personally, I prefer to know-what-i-am-doing-to-my-puter... and besides that, "my method" above requires just to know how to copypaste from a browser window to a texteditor, it works for EVERY freaking distro out there (excluding windows) and it depends on no desktop environment (else there's the Gnome-heavy "ntfs-config" utlity).

This post has been edited by scarecrow: 08 November 2007 - 05:00 PM

0

#14 User is offline   JonEberger 

  • MUB Addict
  • Group: Members
  • Posts: 626
  • Joined: 24-September 04

Posted 08 November 2007 - 04:56 PM

correct me if i'm wrong, but shouldn't "mount -a" reload whatever is in the fstab? this would negate the need for a reboot.
Posted Image
Posted Image
jmernstb@gmail.com
Registered Linux User #381610
0

#15 User is offline   darkscot 

  • casual
  • Group: Members
  • Posts: 94
  • Joined: 05-December 06

Posted 10 November 2007 - 11:08 AM

View Postscarecrow, on Nov 8 2007, 04:51 PM, said:

But personally, I prefer to know-what-i-am-doing-to-my-puter...

I agree with you, but a lot people do not share that view. I am happy to spend a few hours setting up my PC as I want it and like to know what it is that I have been doing. However, for a Linux distro to be competitive it has to offer users an easy (though possibly more long winded) option. I think that is why PCLinuxOS (which I don't actually like) is so popular.

About a year ago a British computer magazine (Computeractive) ran a series on Linux for beginners using Mandriva 2007 as an example. Based on the feedback in the forums a lot of people started with Mandriva but switched to PClinuxOS because certain tasks (e.g. installing to external HD, automounting HD) was easier. People brought up on Windows XP are generally put of by having to type something into a terminal.

Having said all that I have just discovered that Mandriva ALSO has a graphical method of setting up read/write for NTFS drives! Just install 'ntfs-config'! Why is this not more widely know? :unsure:/>
0

Share this topic:


  • 2 Pages +
  • 1
  • 2
  • You cannot start a new topic
  • You cannot reply to this topic

1 User(s) are reading this topic
0 members, 1 guests, 0 anonymous users