MandrivaUsers.org : Enabling DMA on Slackware [solved] - MandrivaUsers.org

Jump to content

Page 1 of 1
  • You cannot start a new topic
  • You cannot reply to this topic

Enabling DMA on Slackware [solved] Having problems

#1 User is offline   ianw1974 

  • Platinum
  • View blog
  • Group: Admin
  • Posts: 14,038
  • Joined: 09-March 05

Posted 28 November 2005 - 12:38 PM

Been trying to enable DMA on Slackware, and am having problems. For some reason, it just won't do it.

When I type the command to enable it, this is what I get:

root@slackware:/# hdparm -d1 /dev/hdc

/dev/hdc:
 setting using_dma to 1 (on)
 HDIO_SET_DMA failed: Operation not permitted
 using_dma    =  0 (off)


This is the info output through hdparm for my drive:

root@slackware:/# hdparm -i /dev/hdc

/dev/hdc:

 Model=Maxtor 6L080M0, FwRev=BANC1G10, SerialNo=L20Z3QPH
 Config={ Fixed }
 RawCHS=16383/16/63, TrkSize=0, SectSize=0, ECCbytes=4
 BuffType=DualPortCache, BuffSize=8192kB, MaxMultSect=16, MultSect=16
 CurCHS=16383/16/63, CurSects=16514064, LBA=yes, LBAsects=156301488
 IORDY=on/off, tPIO={min:120,w/IORDY:120}, tDMA={min:120,rec:120}
 PIO modes:  pio0 pio1 pio2 pio3 pio4
 DMA modes:  mdma0 mdma1 mdma2
 UDMA modes: udma0 udma1 udma2
 AdvancedPM=yes: disabled (255) WriteCache=enabled
 Drive conforms to: (null):

 * signifies the current active mode


No mode seemed to be selected, so I tried the following command, as it recommended with the -d1 parameter to use -X with mdma2 or udma2 (I figured one of these since what is listed above).

I wasn't sure what to select, so tried using the following commands:

hdparm -d1 -X mdm2
hdparm -d1 -X udma2


when I then re-issued the hdparm -i command, it showed an asterisk against whichever option I chose, but DMA remained disabled.

I'm not sure what I need to do to enable it, or whether I actually need to or not. It's a new installation on this system, so can easily reinstall if it's needed. The hard disks are SATA based.
Ian Walker

Light travels faster than sound. This is why some people appear bright until you hear them speak.........

Posted Image1 x systems installed with Debian (squeeze) x86_64 (Xen Server)
Posted Image1 x systems installed with Ubuntu Lucid (10.04 LTS) x86_64 (Laptop)
Posted Image1 x systems installed with Gentoo x86_64 (Desktop)

My Linux Solutions | Linux Systems Limited
0

#2 User is offline   daniewicz 

  • the dude abides
  • Group: Members
  • Posts: 1,897
  • Joined: 01-August 04

Posted 28 November 2005 - 01:15 PM

Is DMA enabled in the BIOS?
0

#3 User is offline   ianw1974 

  • Platinum
  • View blog
  • Group: Admin
  • Posts: 14,038
  • Joined: 09-March 05

Posted 28 November 2005 - 01:18 PM

I've checked the BIOS settings, and can't see anything relating to it as such. The machine is a HP Proliant DL140 G2 Server, and it's BIOS is very limiting!
Ian Walker

Light travels faster than sound. This is why some people appear bright until you hear them speak.........

Posted Image1 x systems installed with Debian (squeeze) x86_64 (Xen Server)
Posted Image1 x systems installed with Ubuntu Lucid (10.04 LTS) x86_64 (Laptop)
Posted Image1 x systems installed with Gentoo x86_64 (Desktop)

My Linux Solutions | Linux Systems Limited
0

#4 User is offline   ianw1974 

  • Platinum
  • View blog
  • Group: Admin
  • Posts: 14,038
  • Joined: 09-March 05

Posted 28 November 2005 - 01:25 PM

The SATA drive is set to AUTO in the BIOS, and against DMA it says "Mode 5".

I'm wondering if this is why I have a problem. From my previous output it shows:

root@slackware:/# hdparm -i /dev/hdc

/dev/hdc:

Model=Maxtor 6L080M0, FwRev=BANC1G10, SerialNo=L20Z3QPH
Config={ Fixed }
RawCHS=16383/16/63, TrkSize=0, SectSize=0, ECCbytes=4
BuffType=DualPortCache, BuffSize=8192kB, MaxMultSect=16, MultSect=16
CurCHS=16383/16/63, CurSects=16514064, LBA=yes, LBAsects=156301488
IORDY=on/off, tPIO={min:120,w/IORDY:120}, tDMA={min:120,rec:120}
PIO modes:  pio0 pio1 pio2 pio3 pio4
DMA modes:  mdma0 mdma1 mdma2
UDMA modes: udma0 udma1 udma2
AdvancedPM=yes: disabled (255) WriteCache=enabled
Drive conforms to: (null):

* signifies the current active mode


now if my BIOS is configured for Mode 5, does this mean my maximum based on the information above is Mode 2?!? I'm just guessing.....
Ian Walker

Light travels faster than sound. This is why some people appear bright until you hear them speak.........

Posted Image1 x systems installed with Debian (squeeze) x86_64 (Xen Server)
Posted Image1 x systems installed with Ubuntu Lucid (10.04 LTS) x86_64 (Laptop)
Posted Image1 x systems installed with Gentoo x86_64 (Desktop)

My Linux Solutions | Linux Systems Limited
0

#5 User is offline   scarecrow 

  • Platinum
  • Group: Platinum
  • Posts: 5,157
  • Joined: 16-February 05

Posted 28 November 2005 - 01:28 PM

You can't enable DMA on SATA drives (as well as SCSI ones, of course). Just leave the I/O settings as they are.
I guess you are using the 2.4.X series' kernel with devfs, else the drive should be /dev/sdx rather than /dev/hdx.

This post has been edited by scarecrow: 28 November 2005 - 01:31 PM

0

#6 User is offline   ianw1974 

  • Platinum
  • View blog
  • Group: Admin
  • Posts: 14,038
  • Joined: 09-March 05

Posted 28 November 2005 - 01:38 PM

Yes, it is a 2.4.x kernel sata.i when I originally installed, and the drive is appearing as /dev/hdc.

I did try changing to User in BIOS and Mode 2, but this didn't make any difference. So what you mentioned above would explain not being able to enable DMA on this type of drive.

I'm going to reinstall with a 2.6.x kernel once I've found where it is on the 10.2 CD, and see if it'll be any better with this anyhow. Is there a reason as to why DMA can't be enabled on SATA drives? Will it not impact performance with it not enabled?
Ian Walker

Light travels faster than sound. This is why some people appear bright until you hear them speak.........

Posted Image1 x systems installed with Debian (squeeze) x86_64 (Xen Server)
Posted Image1 x systems installed with Ubuntu Lucid (10.04 LTS) x86_64 (Laptop)
Posted Image1 x systems installed with Gentoo x86_64 (Desktop)

My Linux Solutions | Linux Systems Limited
0

#7 User is offline   arctic 

  • Platinum
  • View blog
  • Group: Global Moderator
  • Posts: 8,192
  • Joined: 11-June 04

Posted 28 November 2005 - 01:52 PM

I don't know exactly, why DMA does not work with SATA drives but actually, who cares? I have DMA disabled on one machine (AMD 1,2 GHz) as it was getting too unstable with DMA enabled and now, after several months, running without it, I can assure you that the "speed drop-off" is almost nonexistant. You hardly notice any changes.
Also: The 2.4 kernel in Slackware was rather painful for enabling DMA on my main machine, thus I installed the 2.6 kernel that comes on the CDs and it was 100% better imho. hdparm worked well with it.
Mageia 1
0

#8 User is offline   ianw1974 

  • Platinum
  • View blog
  • Group: Admin
  • Posts: 14,038
  • Joined: 09-March 05

Posted 28 November 2005 - 01:56 PM

I'm just installing now using the test26.s kernel option which is apparently a 2.6 kernel. I'll obtain the kernel-source after this and install on the machine.
Ian Walker

Light travels faster than sound. This is why some people appear bright until you hear them speak.........

Posted Image1 x systems installed with Debian (squeeze) x86_64 (Xen Server)
Posted Image1 x systems installed with Ubuntu Lucid (10.04 LTS) x86_64 (Laptop)
Posted Image1 x systems installed with Gentoo x86_64 (Desktop)

My Linux Solutions | Linux Systems Limited
0

#9 User is offline   daniewicz 

  • the dude abides
  • Group: Members
  • Posts: 1,897
  • Joined: 01-August 04

Posted 28 November 2005 - 06:57 PM

Quote

You can't enable DMA on SATA drives


Hmm. I did not know that.

ianw1974:

What kind of throughput do you see on the SATA drive?
0

#10 User is offline   ianw1974 

  • Platinum
  • View blog
  • Group: Admin
  • Posts: 14,038
  • Joined: 09-March 05

Posted 01 December 2005 - 01:25 PM

It's actually quite quick, so think everything must be running OK.

The installation at present is currently running a 2.4 kernel, but we're going to upgrade it shortly which should hopefully improve things further :P/>
Ian Walker

Light travels faster than sound. This is why some people appear bright until you hear them speak.........

Posted Image1 x systems installed with Debian (squeeze) x86_64 (Xen Server)
Posted Image1 x systems installed with Ubuntu Lucid (10.04 LTS) x86_64 (Laptop)
Posted Image1 x systems installed with Gentoo x86_64 (Desktop)

My Linux Solutions | Linux Systems Limited
0

#11 User is offline   scarecrow 

  • Platinum
  • Group: Platinum
  • Posts: 5,157
  • Joined: 16-February 05

Posted 01 December 2005 - 03:01 PM

2.6.15, whenever is ready, will have better SATA support, supposedly including channel tweaks.
I'm slightly at a loss, since the only way I know altering the DMA settings is hdparm, but it does not seem to work well (or at all) with SATA drives.
0

#12 User is offline   ianw1974 

  • Platinum
  • View blog
  • Group: Admin
  • Posts: 14,038
  • Joined: 09-March 05

Posted 01 December 2005 - 03:04 PM

I've just installed kernel 2.6.14.3 on the system, and seems to be working fine so far :P/>
Ian Walker

Light travels faster than sound. This is why some people appear bright until you hear them speak.........

Posted Image1 x systems installed with Debian (squeeze) x86_64 (Xen Server)
Posted Image1 x systems installed with Ubuntu Lucid (10.04 LTS) x86_64 (Laptop)
Posted Image1 x systems installed with Gentoo x86_64 (Desktop)

My Linux Solutions | Linux Systems Limited
0

Share this topic:


Page 1 of 1
  • You cannot start a new topic
  • You cannot reply to this topic

1 User(s) are reading this topic
0 members, 1 guests, 0 anonymous users