MandrivaUsers.org : Installing and Configuring 100dpi fonts - MandrivaUsers.org

Jump to content

Page 1 of 1
  • You cannot start a new topic
  • You cannot reply to this topic

Installing and Configuring 100dpi fonts How to do it.....

#1 User is offline   ianw1974 

  • Platinum
  • View blog
  • Group: Admin
  • Posts: 14,047
  • Joined: 09-March 05

Posted 30 June 2005 - 04:44 PM

First, this is not all my own work. This information has come from a few posts on this forum, some of which I was involved in myself, but have decided to pool it together in a "Tips and Tricks" topic.

Acknowledgements for this go to:

coverup
daniewicz
phantom

from the various posts:

coverup - http://mandrivausers.org/index.php?showtop...hl=100dpi+fonts
daniewicz and phantom - http://mandrivausers.org/index.php?showtop...&hl=DisplaySize

coverup for the ordering of items within /etc/X11/fs/config file
daniewicz for the DisplaySize setting for xorg.conf
phantom for the screen resolution calculation

OK, now let's move on to the main part of this. I have listed effectively what needs to be done. All the editing of files in this tip has been done using vi or vim from the terminal or CLI if you will. For example, in Part 2 you have to edit /etc/X11/fs/config, you will type:

vi config


whilst sat in /etc/X11/fs

Please note, that for editing the files you need to be in superuser mode. To obtain this, type the following at the command prompt.

su (and press enter)
<supply root password> (and press enter)


then continue using the vi or vim command to edit the files. If you are unfamiliar with vi/vim, the commands you're most likely to use are:

i - to insert/modify text
esc - to exit the editing mode
:w - to save the file
:q - to quit

Part 1:

First off, you need to make sure you have the 100dpi fonts installed. In Mandrake 10.1 and higher, it's called xorg-x11-100dpi (or similar wording). If you have 10.0, it's most likely to be xfree86-x11-100dpi or something along those lines.

Part 2:

After this has been installed, we can now look at making a few changes to get everything working. It will still run at 75dpi unless you tell it to. First, the fonts have to be loaded in a particular order.

Edit /etc/X11/fs/config and you'll most likely find that the following lines are as follows:

/usr/X11R6/lib/X11/fonts/75dpi:unscaled,
/usr/X11R6/lib/X11/fonts/100dpi:unscaled,


These lines may be separated by other lines, this is fine. However, the lines need to appear like this:

/usr/X11R6/lib/X11/fonts/100dpi:unscaled,
/usr/X11R6/lib/X11/fonts/75dpi:unscaled,


This is so that it loads in the correct order, ie: 100dpi before 75dpi. If 75dpi is listed first, then it will load these first.

Now you need to edit the following line:

default-resolutions = 75,75,100,100


This is the same, it has to look like this:

default-resolutions = 100,100,75,75


This is because it will load the resolution in what it finds first. Now, save the file, this part is done.

Part3:

Now we need to edit /etc/X11/xorg.conf. In here, there is a section as follows:

Section "Monitor"
Identifier "monitor1"
VendorName "Generic"
ModelName "Flat Panel 1024x768"
HorizSync 31.5-48.5
VertRefresh 40-70
DisplaySize 260 195


You will be missing the important line "DisplaySize". The parameters here differ, from screen resolution to screen resolution. The values above are for 1024x768. How I know this, is because you need to work it out with a screen calculation. This calculation is:

Quote

Screensize multiplied by 25.4 and divided by 100 (eg: 1024 x 25.4/100 = 260 and 768 x 25.4/100 = 195)


Each of the numbers are rounded down. You cannot put numbers with the decimal places, else it won't work. To check and test that you have it configured correctly, there is a command that allows you to check it's configured perfectly. You need to reboot first however before you run this, otherwise it will report your current setup. Below is an example:

xdpyinfo | grep resolution
resolution: 100x100 dots per inch


and now you have 100dpi fonts.
Ian Walker

Light travels faster than sound. This is why some people appear bright until you hear them speak.........

Posted Image2 x systems installed with Ubuntu 14.04 x86_64 (Laptop and Desktop)
Posted Image1 x systems installed with Gentoo x86_64 (Desktop)

My Linux Solutions | Linux Systems Limited
0

#2 User is offline   Lowe 

  • o.O
  • Group: Members
  • Posts: 416
  • Joined: 08-August 04

Posted 06 July 2005 - 08:56 AM

Wouldn't nano be a lot easier than vim? I've used linux for over a year and even i struggle using vim, nano is a LOT easier to use.
0

#3 User is offline   ianw1974 

  • Platinum
  • View blog
  • Group: Admin
  • Posts: 14,047
  • Joined: 09-March 05

Posted 08 July 2005 - 06:18 PM

Can't say I've used nano myself (wasn't aware of it). I tended only to use vi/vim as I knew of it, but sure, any text editor would suffice for amending any of the files mentioned above. :P/>
Ian Walker

Light travels faster than sound. This is why some people appear bright until you hear them speak.........

Posted Image2 x systems installed with Ubuntu 14.04 x86_64 (Laptop and Desktop)
Posted Image1 x systems installed with Gentoo x86_64 (Desktop)

My Linux Solutions | Linux Systems Limited
0

#4 User is offline   polemicz 

  • MUB Addict
  • Group: Members
  • Posts: 644
  • Joined: 19-September 02

Posted 08 July 2005 - 06:28 PM

One good reason to get to know vi is that it is the editor you can use with the rescue boot on cd1.
0

#5 User is offline   coverup 

  • Mandriva Guru
  • Group: Members
  • Posts: 1,279
  • Joined: 08-January 03

Posted 15 August 2005 - 03:57 PM

Setting DisplaySize can be tricky, you may end up with 95x96 dpi, and the fonts may be skightly distorted because of that. A much neater way is to start X using
startx -- -dpi 96

(or use -dpi 100, -dpi 120, etc.)
0

#6 User is offline   Lexicon 

  • Lexicon
  • Group: Members
  • Posts: 801
  • Joined: 23-June 06

Posted 23 June 2006 - 09:58 PM

It is necessary remember of libfreetype6-2.1.10-8plf.i586.rpm and libfreetype6-devel-2.1.10-8plf.i586.rpm
.....Lex
Mandriva 2010
My page
Linux user 363394 Posted Image
0

#7 User is offline   iphitus 

  • Arch Linux Developer, Rocket Scientist
  • View blog
  • Group: Global Moderator
  • Posts: 3,869
  • Joined: 16-April 03

Posted 24 June 2006 - 03:57 AM

Or if you use GNOME, go to it's font properties and bump up the DPI there.
0

#8 User is offline   Lexicon 

  • Lexicon
  • Group: Members
  • Posts: 801
  • Joined: 23-June 06

Posted 13 July 2006 - 12:56 PM

More install
urpmi msfonts-1.2.1-1
.....Lex
Mandriva 2010
My page
Linux user 363394 Posted Image
0

#9 User is offline   ianw1974 

  • Platinum
  • View blog
  • Group: Admin
  • Posts: 14,047
  • Joined: 09-March 05

Posted 13 July 2006 - 01:39 PM

Don't need msfonts on my install of Mandriva 2006. Or even I don't remember installing it when I used Mandrake 10.1 either. And it doesn't exist in the Mandriva 2006 repositories either :o/> so not sure how you'd install it!!! Unless you're not using Mandriva 2006 ;)/>

libfreetype6 and libfreetype6-devel already exist on my system :P/>
Ian Walker

Light travels faster than sound. This is why some people appear bright until you hear them speak.........

Posted Image2 x systems installed with Ubuntu 14.04 x86_64 (Laptop and Desktop)
Posted Image1 x systems installed with Gentoo x86_64 (Desktop)

My Linux Solutions | Linux Systems Limited
0

#10 User is offline   tyme 

  • Serial Slacker
  • View blog
  • Group: Platinum
  • Posts: 13,309
  • Joined: 24-October 02

Posted 13 July 2006 - 03:46 PM

If you have a Windows install on your system, Mandriva has the ability to import fonts from it.

You should also be able to get the msfonts from here.
0

#11 User is offline   Lexicon 

  • Lexicon
  • Group: Members
  • Posts: 801
  • Joined: 23-June 06

Posted 13 July 2006 - 10:21 PM

Quote

libfreetype6 and libfreetype6-devel already exist on my system tongue.gif
,
Must ben version libfreetype6-2.1.10-8plf.i586.rpm but you must recompile this library.

Quote

If you have a Windows


Never ......Lex
Mandriva 2010
My page
Linux user 363394 Posted Image
0

#12 User is offline   ianw1974 

  • Platinum
  • View blog
  • Group: Admin
  • Posts: 14,047
  • Joined: 09-March 05

Posted 14 July 2006 - 06:00 AM

Mine are from official repositories, not plf, maybe this is why you have the problem:

[ian@esprit ~]$ rpm -qa |grep libfreetype
libfreetype6-2.1.10-9.3.20060mdk
libfreetype6-devel-2.1.10-9.3.20060mdk


notice the lack of plf in the filename. Must have come from main, contrib or updates.
Ian Walker

Light travels faster than sound. This is why some people appear bright until you hear them speak.........

Posted Image2 x systems installed with Ubuntu 14.04 x86_64 (Laptop and Desktop)
Posted Image1 x systems installed with Gentoo x86_64 (Desktop)

My Linux Solutions | Linux Systems Limited
0

#13 User is offline   Lexicon 

  • Lexicon
  • Group: Members
  • Posts: 801
  • Joined: 23-June 06

Posted 14 July 2006 - 03:00 PM

It's fine.
I have this library from my Mandriba 2006 Official on 3xDVD, but after instalation and update as default:

rpm -qa | grep libfreetype
libfreetype6-2.1.10-12.mdk2006.0.mde
libfreetype6-devel-2.1.10-12.mdk2006.0.mde

Now

rpm -e --nodeps libfreetype6-2.1.10-12.mdk2006.0.mde libfreetype6-devel-2.1.10-12.mdk2006.0.mde

rpm -i --nodeps ibfreetype6-2.1.10-8plf.i586.rpm libfreetype6-devel-2.1.10-8plf.i586.rpm

This is Konqueror, fons - Verdana

http://lexicon.fm.interia.pl/100dpi.png

.....Lex
Mandriva 2010
My page
Linux user 363394 Posted Image
0

Share this topic:


Page 1 of 1
  • You cannot start a new topic
  • You cannot reply to this topic

1 User(s) are reading this topic
0 members, 1 guests, 0 anonymous users