MandrivaUsers.org : Shutdown time [solved] - MandrivaUsers.org

Jump to content

Page 1 of 1
  • You cannot start a new topic
  • You cannot reply to this topic

Shutdown time [solved] currently 30 seconds

#1 User is offline   AussieJohn 

  • MAGEIA Loyal
  • Group: Members
  • Posts: 3,134
  • Joined: 25-August 03

Posted 08 February 2016 - 06:06 AM

Hello everyone.

Currently when you right click on the desktop and select Leave and then Restart Computer it takes an agonising 30 seconds.
I would like to change it to 10 seconds which is more than a reasonable time for all practical purposes.
Where do I go into to change it. Prefer GUI if possible but not rigid on this.

Thanks in advance. John (now 81 years young) :-)
The Computer future is here TODAY ..... Mageia-5.0, KDE4, Dolphin, K3B, Grip, Audacious, Totem, Kaffeine, SVLC, Kmail, Libre-Office, Scribus, XSane, Gimp, OpenShot, FireFox, FlightGear, Filelight, Gwenview, Geeqie, GoogleEarth, Skype, Pysol-FC.

Corsair Obsidian 750D Full Tower Case (full Window), AMD Athlon-FX8120 8-Core 3.1Ghz Processor, Gigabyte GA-990FXA-UD3 USB3 rev.4 MainBoard, Gigabyte Nvidia-GeForce-9600-GT VideoCard, 16Gb Corsair "Vengeance" DDR3 Memory, 1 x Corsair 240Gb SSD Neutron Hard Drive, WD SATA-II 500GB 16mb HDD, 2 x LG Sata DVD-R/RW Burners, LG 27" LED LCD HDMI Monitor, Hewlitt-Packard PhotoSmart 6510 Printer, APC BackUPS-CS-650 UPS, Corsair HX650W Power Supply, Vantec Dual HDD Docking Station SATA-USB3.

ADSL-2+ Internet Connection_100Gb (Bigpond)

JOHN. (82yrs, Young) Registered LINUX user #318452
0

#2 User is offline   ianw1974 

  • Platinum
  • Group: Admin
  • Posts: 14,092
  • Joined: 09-March 05

Posted 10 February 2016 - 12:56 PM

Hi John,

A lot of this could be due to services on your system, as it's shutting them all down when you turn it off. We can alleviate the problem by disabling unnecessary services. However, I would need to know what services are enabled. Easier will be a console, because I can filter them.

So if you open a console and then do this:

su (enter root password when prompted)
chkconfig --list | grep :on


that will filter all services with the "on" parameter, that shows they are enabled. You can then copy and paste it into your reply. We could do it by screenshots, but it would be too many screenshots to get all the info, and it would show all services enabled and disabled.

I'm not using Mageia 5, so am assuming they are still using chkconfig to list services. If not, I'll create myself a Virtual Machine and then take a look for an alternative command to provide you.
Ian Walker

Light travels faster than sound. This is why some people appear bright until you hear them speak.........

My Linux Solutions | Linux Systems Limited
0

#3 User is offline   AussieJohn 

  • MAGEIA Loyal
  • Group: Members
  • Posts: 3,134
  • Joined: 25-August 03

Posted 10 February 2016 - 03:16 PM

Thanks Ian for your response.

The time is not dictated by services having to be closed down, I am pretty sure because it is the same on all 3 of my Mageia computers
and shows in the countdown displayed on the pop up listing the choices for shutting down etc. If shut down is selected then the timer stops no longer operates and the procedure only then finally takes about 8 to10 seconds or so to complete.
It is when you select reboot that the full 30 seconds takes place. There is a config somewhere that is set at 30 seconds but I don't know where to look.
What ever file that popup is, is where I think the timer instruction is but I don't know where or what that file is.
I hope you see what I am getting at and hope to do.
Cheers. John

This post has been edited by AussieJohn: 10 February 2016 - 03:19 PM

The Computer future is here TODAY ..... Mageia-5.0, KDE4, Dolphin, K3B, Grip, Audacious, Totem, Kaffeine, SVLC, Kmail, Libre-Office, Scribus, XSane, Gimp, OpenShot, FireFox, FlightGear, Filelight, Gwenview, Geeqie, GoogleEarth, Skype, Pysol-FC.

Corsair Obsidian 750D Full Tower Case (full Window), AMD Athlon-FX8120 8-Core 3.1Ghz Processor, Gigabyte GA-990FXA-UD3 USB3 rev.4 MainBoard, Gigabyte Nvidia-GeForce-9600-GT VideoCard, 16Gb Corsair "Vengeance" DDR3 Memory, 1 x Corsair 240Gb SSD Neutron Hard Drive, WD SATA-II 500GB 16mb HDD, 2 x LG Sata DVD-R/RW Burners, LG 27" LED LCD HDMI Monitor, Hewlitt-Packard PhotoSmart 6510 Printer, APC BackUPS-CS-650 UPS, Corsair HX650W Power Supply, Vantec Dual HDD Docking Station SATA-USB3.

ADSL-2+ Internet Connection_100Gb (Bigpond)

JOHN. (82yrs, Young) Registered LINUX user #318452
0

#4 User is offline   ianw1974 

  • Platinum
  • Group: Admin
  • Posts: 14,092
  • Joined: 09-March 05

Posted 10 February 2016 - 06:17 PM

Yep, I think I know what you mean, although have no idea where to look. Let me make a default install of Mageia, and I'll see if I can then try and find the setting that you're talking about.
Ian Walker

Light travels faster than sound. This is why some people appear bright until you hear them speak.........

My Linux Solutions | Linux Systems Limited
0

#5 User is offline   ianw1974 

  • Platinum
  • Group: Admin
  • Posts: 14,092
  • Joined: 09-March 05

Posted 10 February 2016 - 06:23 PM

For now, some additional info as I investigate:

https://forums.magei...7&t=7923#p50327

Quote

That is just some arbitrary definition. If you have a slow harddisk, and some services running that need to be stopped beforehand, shutdown might take half a minute.


If I find anymore in the meantime, I'll try and help, otherwise, I'll be installing it to check it out and find a solution.
Ian Walker

Light travels faster than sound. This is why some people appear bright until you hear them speak.........

My Linux Solutions | Linux Systems Limited
0

#6 User is offline   ianw1974 

  • Platinum
  • Group: Admin
  • Posts: 14,092
  • Joined: 09-March 05

Posted 10 February 2016 - 06:34 PM

John,

Not found anything right yet, just some bugs, but nothing hinting at a solution. So am downloading Mageia 5 and I'll make an install tomorrow. Please let me know what desktop did you install? KDE4? As per your signature?
Ian Walker

Light travels faster than sound. This is why some people appear bright until you hear them speak.........

My Linux Solutions | Linux Systems Limited
0

#7 User is offline   AussieJohn 

  • MAGEIA Loyal
  • Group: Members
  • Posts: 3,134
  • Joined: 25-August 03

Posted 11 February 2016 - 04:01 PM

Thanks Ian.
Yes using Mageia-5 64 Kde4.

Special thanks for taking the time.

Cheers. John.
The Computer future is here TODAY ..... Mageia-5.0, KDE4, Dolphin, K3B, Grip, Audacious, Totem, Kaffeine, SVLC, Kmail, Libre-Office, Scribus, XSane, Gimp, OpenShot, FireFox, FlightGear, Filelight, Gwenview, Geeqie, GoogleEarth, Skype, Pysol-FC.

Corsair Obsidian 750D Full Tower Case (full Window), AMD Athlon-FX8120 8-Core 3.1Ghz Processor, Gigabyte GA-990FXA-UD3 USB3 rev.4 MainBoard, Gigabyte Nvidia-GeForce-9600-GT VideoCard, 16Gb Corsair "Vengeance" DDR3 Memory, 1 x Corsair 240Gb SSD Neutron Hard Drive, WD SATA-II 500GB 16mb HDD, 2 x LG Sata DVD-R/RW Burners, LG 27" LED LCD HDMI Monitor, Hewlitt-Packard PhotoSmart 6510 Printer, APC BackUPS-CS-650 UPS, Corsair HX650W Power Supply, Vantec Dual HDD Docking Station SATA-USB3.

ADSL-2+ Internet Connection_100Gb (Bigpond)

JOHN. (82yrs, Young) Registered LINUX user #318452
0

#8 User is offline   ianw1974 

  • Platinum
  • Group: Admin
  • Posts: 14,092
  • Joined: 09-March 05

Posted 11 February 2016 - 04:48 PM

I've made a virtual machine. Now my question is. When I click an option to shutdown the machine, I'm given a dialog box if I want to then click the reboot or shutdown option. The dialog box has a timer of 30 seconds. Is this what you are referring to? That in case you don't click anything, it will wait 30 seconds, and then restart? Or do you mean that you click restart, the process takes too long to complete? (IE: not related to the timer/dialog box).

Please let me know.
Ian Walker

Light travels faster than sound. This is why some people appear bright until you hear them speak.........

My Linux Solutions | Linux Systems Limited
0

#9 User is offline   AussieJohn 

  • MAGEIA Loyal
  • Group: Members
  • Posts: 3,134
  • Joined: 25-August 03

Posted 12 February 2016 - 06:29 AM

Thanks again Ian.
Yes to the final comment. When I select restart and do nothing else it runs the full 30second timer and I would like to cut it to about 10 seconds. There doesn't seem to be any real purpose to it being set at 30 seconds.

Cheers. John
The Computer future is here TODAY ..... Mageia-5.0, KDE4, Dolphin, K3B, Grip, Audacious, Totem, Kaffeine, SVLC, Kmail, Libre-Office, Scribus, XSane, Gimp, OpenShot, FireFox, FlightGear, Filelight, Gwenview, Geeqie, GoogleEarth, Skype, Pysol-FC.

Corsair Obsidian 750D Full Tower Case (full Window), AMD Athlon-FX8120 8-Core 3.1Ghz Processor, Gigabyte GA-990FXA-UD3 USB3 rev.4 MainBoard, Gigabyte Nvidia-GeForce-9600-GT VideoCard, 16Gb Corsair "Vengeance" DDR3 Memory, 1 x Corsair 240Gb SSD Neutron Hard Drive, WD SATA-II 500GB 16mb HDD, 2 x LG Sata DVD-R/RW Burners, LG 27" LED LCD HDMI Monitor, Hewlitt-Packard PhotoSmart 6510 Printer, APC BackUPS-CS-650 UPS, Corsair HX650W Power Supply, Vantec Dual HDD Docking Station SATA-USB3.

ADSL-2+ Internet Connection_100Gb (Bigpond)

JOHN. (82yrs, Young) Registered LINUX user #318452
0

#10 User is offline   ianw1974 

  • Platinum
  • Group: Admin
  • Posts: 14,092
  • Joined: 09-March 05

Posted 12 February 2016 - 06:06 PM

I expect that to be a KDE setting somewhere if it's possible to decrease it.
Ian Walker

Light travels faster than sound. This is why some people appear bright until you hear them speak.........

My Linux Solutions | Linux Systems Limited
0

#11 User is offline   ianw1974 

  • Platinum
  • Group: Admin
  • Posts: 14,092
  • Joined: 09-March 05

Posted 12 February 2016 - 06:08 PM

Doing a generic search gives this:

https://forum.kde.or...t=83273#p140480

the 30 seconds is hard-coded. So you can't change it. But what you can do is disable the confirmation box which is what is displayed for 30 seconds. So if you do that, it will then just shutdown or reboot instead of waiting for 30 seconds.

From the link above:

Quote

disable the confirmation in kde's systemsettings, under [advanced->sessionmanager]

Ian Walker

Light travels faster than sound. This is why some people appear bright until you hear them speak.........

My Linux Solutions | Linux Systems Limited
1

#12 User is offline   ianw1974 

  • Platinum
  • Group: Admin
  • Posts: 14,092
  • Joined: 09-March 05

Posted 12 February 2016 - 07:54 PM

John,

See attached screenshots.

01.png - go to Tools, System Tools, System Settings.
02.png - scroll down for start/shutdown options and double-click.
03.png - disable the confirm logout option.
04.png - this is how the screen should look after you disabled the logout option. Click Apply.

now choose restart or shutdown or whichever you want, and you'll now find that it will do it immediately instead of waiting 30 seconds.

Attached File(s)

  • Attached File  01.png (447.94K)
    Number of downloads: 6
  • Attached File  02.png (455.15K)
    Number of downloads: 5
  • Attached File  03.png (420.72K)
    Number of downloads: 8
  • Attached File  04.png (423.16K)
    Number of downloads: 8

Ian Walker

Light travels faster than sound. This is why some people appear bright until you hear them speak.........

My Linux Solutions | Linux Systems Limited
1

#13 User is offline   AussieJohn 

  • MAGEIA Loyal
  • Group: Members
  • Posts: 3,134
  • Joined: 25-August 03

Posted 12 February 2016 - 08:13 PM

Thank you Ian.
Cheers. John.
The Computer future is here TODAY ..... Mageia-5.0, KDE4, Dolphin, K3B, Grip, Audacious, Totem, Kaffeine, SVLC, Kmail, Libre-Office, Scribus, XSane, Gimp, OpenShot, FireFox, FlightGear, Filelight, Gwenview, Geeqie, GoogleEarth, Skype, Pysol-FC.

Corsair Obsidian 750D Full Tower Case (full Window), AMD Athlon-FX8120 8-Core 3.1Ghz Processor, Gigabyte GA-990FXA-UD3 USB3 rev.4 MainBoard, Gigabyte Nvidia-GeForce-9600-GT VideoCard, 16Gb Corsair "Vengeance" DDR3 Memory, 1 x Corsair 240Gb SSD Neutron Hard Drive, WD SATA-II 500GB 16mb HDD, 2 x LG Sata DVD-R/RW Burners, LG 27" LED LCD HDMI Monitor, Hewlitt-Packard PhotoSmart 6510 Printer, APC BackUPS-CS-650 UPS, Corsair HX650W Power Supply, Vantec Dual HDD Docking Station SATA-USB3.

ADSL-2+ Internet Connection_100Gb (Bigpond)

JOHN. (82yrs, Young) Registered LINUX user #318452
0

#14 Guest_antonio_*

  • Group: Guests

Post icon  Posted 24 January 2017 - 08:54 AM

View Postianw1974, on 12 February 2016 - 07:54 PM, said:

John,

See attached screenshots.

01.png - go to Tools, System Tools, System Settings.
02.png - scroll down for start/shutdown options and double-click.
03.png - disable the confirm logout option.
04.png - this is how the screen should look after you disabled the logout option. Click Apply.

now choose restart or shutdown or whichever you want, and you'll now find that it will do it immediately instead of waiting 30 seconds.




great explanation thank you
i was looking for the same solution and i found it here
0

Share this topic:


Page 1 of 1
  • You cannot start a new topic
  • You cannot reply to this topic

1 User(s) are reading this topic
0 members, 1 guests, 0 anonymous users