MandrivaUsers.org : Webdav issues: Owncloud - MandrivaUsers.org

Jump to content

  • 2 Pages +
  • 1
  • 2
  • You cannot start a new topic
  • You cannot reply to this topic

Webdav issues: Owncloud Post install check failure

#1 User is offline   xboxboy 

  • MUB Addict
  • Group: Members
  • Posts: 506
  • Joined: 02-October 07

Posted 06 May 2014 - 04:02 AM

Hi all. I have posted on Mageia forums, but so far no luck :(

So I'll run it past the faithful group here :)/>/>/>

Clean install of Mageia 4 with /home on a separate partition.

So I install, via MCC, the owncloud server: Took a bit of messing around to get a static ip on my home network.

Then I point browser at http://MYipaddy/owncloud which brought up the admin page: I tried to set the data directory as /home/owncloud/data. That failed due to permissions, I found on the web this command


chown -R apache:apache /home/owncloud/data 



Which then let me get past the admin page. Now im stuck on post setup check with:

Your web server is not yet properly setup to allow files synchronization because the WebDAV interface seems to be broken.
Please double check the installion guides



So, I've checked the log, and this seems to be the issue:


{"app":"core","message":"isWebDAVWorking: NO - Reason: [CURL] Error while making request:
Connection timed out after 10004 milliseconds (error code: 28) (sabre_DAV_Exception)", "level":2,"time....etc



So, was my change of permissions the right thing to do? How do I proceed regarding this WebDAV issue?

xboxboy
Asus P5Q Pro; E2200; 6GB RAM; 500GB boot drive, with additional 640GB RAID1 array; LG DVD RW; Linux Mint 13, 64 Bit: KDE 4.8.4
0

#2 User is offline   paul 

  • Kimalicious
  • Group: Admin
  • Posts: 5,683
  • Joined: 07-September 02

Posted 06 May 2014 - 09:44 AM

I don't know owncloud, but my first guess is apache Directory directive
example:

        <Directory "/home/owncloud/data/">
                Options Indexes FollowSymLinks MultiViews
                AllowOverride All
                Order allow,deny
                allow from all
        </Directory>



it's the allow from all that's the important bit.
apache needs to own the directory AND be told that requests can be made to that directory.
0

#3 User is offline   xboxboy 

  • MUB Addict
  • Group: Members
  • Posts: 506
  • Joined: 02-October 07

Posted 06 May 2014 - 02:36 PM

Hi Paul. You could well be right. I'm not sure how I go about checking that out. Could you please point me in the right direction?
Asus P5Q Pro; E2200; 6GB RAM; 500GB boot drive, with additional 640GB RAID1 array; LG DVD RW; Linux Mint 13, 64 Bit: KDE 4.8.4
0

#4 User is offline   ianw1974 

  • Platinum
  • Group: Admin
  • Posts: 14,080
  • Joined: 09-March 05

Posted 08 May 2014 - 05:35 AM

Changing the owner of data is correct. You probably need to enable the webdav module in apache - that's what your error is throwing. I found a post that curl is optional, so another way is edit php.ini find the php_curl module in there, and comment it out. Maybe curl is just throwing an error because something is not quite correct.

Two things to check at least.

Normally I download and extract manually from owncloud. This means you get something without any "distro" tampering - which is something you might be experiencing because you installed it via MCC. Also you don't necessarily have the newest version available. Too many times I've had problems with distros and installing from the repo, for example joomla, redmine, owncloud (Debian when I experienced problems). Sometimes it's just easier and better to do it a bit more "manual" and download and extract manually.
Ian Walker

Light travels faster than sound. This is why some people appear bright until you hear them speak.........

My Linux Solutions | Linux Systems Limited
0

#5 User is offline   xboxboy 

  • MUB Addict
  • Group: Members
  • Posts: 506
  • Joined: 02-October 07

Posted 08 May 2014 - 01:02 PM

Hi Ian, valid comments. I would like to get the version from the repo working for ease of updating. If this proves too hard, we will go direct.

Ok, so a bit of research shows I need to modify a file called httpd.conf: I have found two:

/usr/lib/tmpfiles.d/httpd.conf
/etc/httpd/conf/httpd.conf


I assume it's the second one? This appears to be the original files, with lots of remarks. It's only got a few directory sections: /, /var/www, /var/www/cgi-bin

So I guess I need to add something like what Paul has suggested above?

Thanks guys, appreciate the help.
Asus P5Q Pro; E2200; 6GB RAM; 500GB boot drive, with additional 640GB RAID1 array; LG DVD RW; Linux Mint 13, 64 Bit: KDE 4.8.4
0

#6 User is offline   ianw1974 

  • Platinum
  • Group: Admin
  • Posts: 14,080
  • Joined: 09-March 05

Posted 10 May 2014 - 05:06 PM

The bit paul wrote is for helping with access to the directory, it doesn't fix your webdav issue. That's something you need to get apache configured for. Maybe you need to install some extra packages?

Trying installing: apache-mod_dav

I found this when googling "mageia apache webdav".

Restart apache afterwards, and try again.
Ian Walker

Light travels faster than sound. This is why some people appear bright until you hear them speak.........

My Linux Solutions | Linux Systems Limited
0

#7 User is offline   xboxboy 

  • MUB Addict
  • Group: Members
  • Posts: 506
  • Joined: 02-October 07

Posted 11 May 2014 - 12:53 PM

Ian. What an interesting round trip.

So I install apache-mod_dav, then while that's finished, I get told there are updates: Seeing owncloud as one of them, I don't think and update all........

Then I get told I'm an untrusted domain by owncloud.

So it takes a bit of time on IRC to work out whats going on, basically add my owncloud host's ip as a trusted domain, and logged straight in!

So I now have an Owncloud server set up! Yes!

Let me see if I can configure my other pc's and phones to access it.
Asus P5Q Pro; E2200; 6GB RAM; 500GB boot drive, with additional 640GB RAID1 array; LG DVD RW; Linux Mint 13, 64 Bit: KDE 4.8.4
0

#8 User is offline   xboxboy 

  • MUB Addict
  • Group: Members
  • Posts: 506
  • Joined: 02-October 07

Posted 12 May 2014 - 01:12 PM

So tonight's goal was to get https working with owncloud

I think I went the long way round: I started generating keys: but was then advised to try connecting via: https://IP.address/owncloud

And I could, which then allowed me to enter the admin settings and force https redirection

I now need to learn how to add self generated certificates to shut firefox up
Asus P5Q Pro; E2200; 6GB RAM; 500GB boot drive, with additional 640GB RAID1 array; LG DVD RW; Linux Mint 13, 64 Bit: KDE 4.8.4
0

#9 User is offline   ianw1974 

  • Platinum
  • Group: Admin
  • Posts: 14,080
  • Joined: 09-March 05

Posted 13 May 2014 - 05:39 PM

You probably already had self-signed certificates by default, if you connected to owncloud with https from the beginning. Firefox will shout about self-signed certificates. If you want to generate free one's which are verified Class I certs, you can get from http://startssl.com
Ian Walker

Light travels faster than sound. This is why some people appear bright until you hear them speak.........

My Linux Solutions | Linux Systems Limited
0

#10 User is offline   xboxboy 

  • MUB Addict
  • Group: Members
  • Posts: 506
  • Joined: 02-October 07

Posted 18 May 2014 - 10:55 AM

Ian, firefox allows me to add an exception, and make it permanent. When I added the client to my desktop it complained about certificates, but it works fine.

Now I just want to confirm that the system is safe:

So, can you confirm that the chown line I ran earlier in the thread is ok?

In the firewall section of MCC I have enabled webserver. I guess I should enable ssh-server so I can log in and admin/update it remotely.

Is this locked down securely with these enabled? I plan to tuck the server away in a corner, and just update it. It's not going to be used in any other task in the near future.
Asus P5Q Pro; E2200; 6GB RAM; 500GB boot drive, with additional 640GB RAID1 array; LG DVD RW; Linux Mint 13, 64 Bit: KDE 4.8.4
0

#11 User is offline   ianw1974 

  • Platinum
  • Group: Admin
  • Posts: 14,080
  • Joined: 09-March 05

Posted 20 May 2014 - 10:59 AM

On private network yes it's enough, but if you will access it from the internet then you'll need to secure SSH with public keys instead of passwords, and also install something like denyhosts to protect SSH from being attacked by people trying to login to your server. Can even change SSH to run on a different port than port 22, to also minimise the risk.

And yes, the chown is fine, because you upload everything using the web browser which connects to the web server, and the web server needs access to that folder/directory to save any files you upload. I expect all of that is in the owncloud docs.
Ian Walker

Light travels faster than sound. This is why some people appear bright until you hear them speak.........

My Linux Solutions | Linux Systems Limited
0

#12 User is offline   xboxboy 

  • MUB Addict
  • Group: Members
  • Posts: 506
  • Joined: 02-October 07

Posted 22 May 2014 - 10:13 AM

Thanks Ian. I'm a little confused regarding the network arrangement.

This owncloud server is connected to my router, which connects all PC's on the network to the internet. Although I don't intend to access this owncloud server from outside my router controlled network, I'm not sure if that means I should be playing with ssh keys and changing ports. Can you clear that up for me please?

Many thanks,
Xboxbox
Asus P5Q Pro; E2200; 6GB RAM; 500GB boot drive, with additional 640GB RAID1 array; LG DVD RW; Linux Mint 13, 64 Bit: KDE 4.8.4
0

#13 User is offline   ianw1974 

  • Platinum
  • Group: Admin
  • Posts: 14,080
  • Joined: 09-March 05

Posted 23 May 2014 - 12:24 PM

If you aren't natting on the router (port-forwarding) to gain access to it externally, then no, you won't need to. Then you are just using it for internal use on your private network.
Ian Walker

Light travels faster than sound. This is why some people appear bright until you hear them speak.........

My Linux Solutions | Linux Systems Limited
0

#14 User is offline   xboxboy 

  • MUB Addict
  • Group: Members
  • Posts: 506
  • Joined: 02-October 07

Posted 24 May 2014 - 07:19 AM

Thanks Ian. So if I set up ssh on it for admin reasons, I should be ok.

Thank you sooo much.
Asus P5Q Pro; E2200; 6GB RAM; 500GB boot drive, with additional 640GB RAID1 array; LG DVD RW; Linux Mint 13, 64 Bit: KDE 4.8.4
0

#15 User is offline   ianw1974 

  • Platinum
  • Group: Admin
  • Posts: 14,080
  • Joined: 09-March 05

Posted 24 May 2014 - 03:22 PM

Yep, you'll be fine :)/>
Ian Walker

Light travels faster than sound. This is why some people appear bright until you hear them speak.........

My Linux Solutions | Linux Systems Limited
0

Share this topic:


  • 2 Pages +
  • 1
  • 2
  • You cannot start a new topic
  • You cannot reply to this topic

1 User(s) are reading this topic
0 members, 1 guests, 0 anonymous users